SitePoint Sponsor

User Tag List

Results 1 to 5 of 5

Hybrid View

  1. #1
    SitePoint Guru aamonkey's Avatar
    Join Date
    Sep 2004
    Location
    kansas
    Posts
    953
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    "parenting" movieclips to another

    I'm new to flash but I know After Effects very well. In after effects you can "parent" layers to another so that when you animate the position, rotation, etc. of an object the other children move as though they were all one layer.

    I'm trying to do this in flash with AS 2. I have a map mc that I am animating via actionscript, and I also have several star symbols that are being generated in the script. What I'm looking for is a way to "stick" the stars on the map mc so that when I move the map mc (via the Tween class) the stars follow.

    I've done a ton of searching, just apparently not using the correct terms....

  2. #2
    SitePoint Guru krityx's Avatar
    Join Date
    Jan 2006
    Location
    Around
    Posts
    634
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    in flash you just put everything into one big movie clip and animate that.


  3. #3
    SitePoint Guru aamonkey's Avatar
    Join Date
    Sep 2004
    Location
    kansas
    Posts
    953
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by krityx View Post
    in flash you just put everything into one big movie clip and animate that.
    so how do I do that in AS 2?

  4. #4
    SitePoint Guru [Paul Ferrie]'s Avatar
    Join Date
    Oct 2007
    Location
    Glasgow, Scotland, UK
    Posts
    853
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    in flash we have _parent, _root, this.

    I think it's one of these your looking for
    .:To me AS is like LEGO, Only for the big Kids :.
    - Site - Blog - Glasgow Flasher
    bringmadeleinehome.com

  5. #5
    SitePoint Evangelist ferrari_chris's Avatar
    Join Date
    Mar 2008
    Location
    NP, New Zealand
    Posts
    576
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    If you're loading the stars in through Actionscript, try loading them onto your map mc instead of the _root and see if that works.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •