SitePoint Sponsor

User Tag List

Results 1 to 14 of 14
  1. #1
    SitePoint Wizard bronze trophy PicnicTutorials's Avatar
    Join Date
    Dec 2007
    Location
    Carlsbad, California, United States
    Posts
    3,658
    Mentioned
    15 Post(s)
    Tagged
    0 Thread(s)

    I'm trying to get music and flash equalizer to show/play on my website.

    Good morning,

    This is my first time posting in the flash forum - hello all! It's also my first attempt at anything flash so excuse my ignorance. First things first - I'm aware that music can be considered annoying, so the user will have complete control and it will be implemented in a tasteful manner. OK... so below I'm going to give anyone reading this all the information and code that I currently have in hopes that it makes it easier for someone to help me. So I guess my question is: What ingredient am I missing? How do I get this to play and work? As you can see in the test page, the equalizer shows - only it doesn't work and play the song. Thanks in advance!

    So here is the equalizer that I am trying to install
    http://www.flashden.net/item/simple-...equalizer/6598

    Here is my test page - the red flash equalizer is in the bottom right corner.
    http://www.ericwwatson.com/flashtest.php

    Here is the Valid code that I'm trying to include it in the page with
    Code:
    <object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" height="30" width="100"
    codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=7,0,68,0">
     <param name="movie" value="audio/tinymusicplayer.swf">
    <param name=wmode value=transparent> 
    <!--[if !IE]> <-->
    <object type="application/x-shockwave-flash" data="audio/tinymusicplayer.swf" height="30" width="100">
     <param name="pluginurl" value="http://www.macromedia.com/go/getflashplayer">
    <param name=wmode value=transparent>
    Alternate content
    </object>
    <!--> <![endif]-->
    </object>
    And there are 3 files (and the song itself) all sitting in the same "audio" folder that I need to somehow incorporate together. This is the part that has got me confused. Within the object tag am I just supposed to be linking to the .swf? And then that calls the music file? The files are...

    1) tinymusicplayer.swf
    2) tinymusicplayer.fla
    3) tiny_songs.xml
    4) madonna.mp3

    Here are the contents of the .xml file. The directions (below) say that all you need to do is edit the .xml file to make any changes to the songs and appearance of the equalizer. However, editing this has no effect for me?
    Code:
    <player>
    <songs>
    <!-- Repeat this for every song you want to add, you can add unlimited number of songs -->
    <song>
    <filename>madonna.mp3</filename>
    </song>
    <song>
    <filename>StompBox.mp3</filename>
    </song>
    </songs>
    <!-- Color of the letters -->
    <color1>0x222222</color1>
    <!-- Color of the bars -->
    <color2>0x0000ff</color2>
    <!-- 1 set of equalizer bars or 2 -->
    <channels>1</channels>
    </player>
    Here are the only directions that come with it
    Thank you for downloading: <Simple Music Button with Real Equalizer >

    Included are:

    * Flash CS3 Flash File, XML configuration file

    How to modify the file:

    Load the "fla" file in your Flash CS3, this file only runs in this version of Flash.
    You can make it run even without compile the "fla", because all the config is done in the XML file.
    So drop the "swf" on your page, config the XML and ready to run.

    Click on the letters to start/stop the music.

    This streaming music player has the following features:

    * Resizable, fully color configurable via XML.
    * The songs are loaded in streaming mode via XML file. Unlimited number of songs, loop mode; when the last song ends, the first starts again.
    * Real equalizer bars that interacts with the music.
    * You can choose if you want 1 equalizer bars set or 2, via XML. When you choose 1 equalizer bars set, this set represents both channels added.

    Enjoy!

    So hopefully all this info helps and it's not just "to much to look at". Thanks a lot for any advice! Have a good one!
    Last edited by PicnicTutorials; Oct 1, 2008 at 07:42.

  2. #2
    Is Still Alive silver trophybronze trophy RetroNetro's Avatar
    Join Date
    Jul 2003
    Location
    Texas
    Posts
    6,883
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    It works if you go direct to the .swf file: http://www.ericwwatson.com/audio/tinymusicplayer.swf so it must be something with the embed code.

  3. #3
    SitePoint Wizard bronze trophy PicnicTutorials's Avatar
    Join Date
    Dec 2007
    Location
    Carlsbad, California, United States
    Posts
    3,658
    Mentioned
    15 Post(s)
    Tagged
    0 Thread(s)
    Thanks BPartch!

    Uh... well that's something at least! I'm thinking I need to also link to the .xml file within the object tag. I'll keep working on it.

  4. #4
    SitePoint Wizard bronze trophy PicnicTutorials's Avatar
    Join Date
    Dec 2007
    Location
    Carlsbad, California, United States
    Posts
    3,658
    Mentioned
    15 Post(s)
    Tagged
    0 Thread(s)
    Oh! This is driving me crazy - I can't stand being this lost! OK, so I stripped everything out and just used this embeded code. So that should work right? But it doesn't. And it still works going strait to the .swf as you did. I'm missing something - I just have no idea what it is?? Any suggestions?

    <embed scale="noscale" quality="high" wmode="transparent" src="audio/tinymusicplayer.swf"></embed>

    Edit - here is a site which has incorperated the exact equalizer with music. I of course can't figure out how they did it. I tried using their SWFObject generated code, but to no avail! http://www.new-wavemedia.com/

  5. #5
    SitePoint Wizard bronze trophy PicnicTutorials's Avatar
    Join Date
    Dec 2007
    Location
    Carlsbad, California, United States
    Posts
    3,658
    Mentioned
    15 Post(s)
    Tagged
    0 Thread(s)
    Bump

  6. #6
    Community Advisor silver trophy

    Join Date
    Nov 2006
    Location
    UK
    Posts
    2,559
    Mentioned
    40 Post(s)
    Tagged
    1 Thread(s)
    At the test url the swf is looking for
    http://www.ericwwatson.com/tiny_songs.xml and not finding it

  7. #7
    SitePoint Wizard bronze trophy PicnicTutorials's Avatar
    Join Date
    Dec 2007
    Location
    Carlsbad, California, United States
    Posts
    3,658
    Mentioned
    15 Post(s)
    Tagged
    0 Thread(s)
    Hello,

    Well it should be looking in http://www.ericwwatson.com/audio/tiny_songs.xml

    All the files are sitting in the same folder. So whats that mean? How do I change that? Thanks!

  8. #8
    SitePoint Wizard bronze trophy PicnicTutorials's Avatar
    Join Date
    Dec 2007
    Location
    Carlsbad, California, United States
    Posts
    3,658
    Mentioned
    15 Post(s)
    Tagged
    0 Thread(s)
    Thanks EastCoast - that did it! Your the man! I moved the .xml file to the root. How could you tell where the .swf was looking?

  9. #9
    Community Advisor silver trophy

    Join Date
    Nov 2006
    Location
    UK
    Posts
    2,559
    Mentioned
    40 Post(s)
    Tagged
    1 Thread(s)
    I use charles web debugging proxy, it shows at a glance what is (and isn't) being loaded.
    It's a great developer tool when debugging anything that depends on loading external data sources

  10. #10
    SitePoint Wizard bronze trophy PicnicTutorials's Avatar
    Join Date
    Dec 2007
    Location
    Carlsbad, California, United States
    Posts
    3,658
    Mentioned
    15 Post(s)
    Tagged
    0 Thread(s)
    Cool, I'll check that out! I've encountered a small problem though. Continuos music play from page to page. Really the only fix are frames - and I'm not doing that! And I've realized that if the user clicks it "off" - that setting does't keep from page to page. So I have to figure out a way to make it "off" by default. Can I do that through the xml file - or the object tag? Or does that need to happpen by editing the .fla file? If so, I'm S-O-L because I don't have a flash editor.

  11. #11
    SitePoint Guru krityx's Avatar
    Join Date
    Jan 2006
    Location
    Around
    Posts
    634
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    you can use the SharedObject class to do that but you must edit the flash file unfortunately.


  12. #12
    SitePoint Wizard bronze trophy PicnicTutorials's Avatar
    Join Date
    Dec 2007
    Location
    Carlsbad, California, United States
    Posts
    3,658
    Mentioned
    15 Post(s)
    Tagged
    0 Thread(s)
    Ewww - bummer - I was afraid of that!

    Feel free to say no, but I'd thought it couldn't hurt to ask. If it's easy, can anyone edit the .fla file for me? I'll gladly do some CSS/html work/trouble shooting or whatever in return. Thanks a bunch!

  13. #13
    SitePoint Guru krityx's Avatar
    Join Date
    Jan 2006
    Location
    Around
    Posts
    634
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    sure just post the fla and i'll have a look at it


  14. #14
    SitePoint Wizard bronze trophy PicnicTutorials's Avatar
    Join Date
    Dec 2007
    Location
    Carlsbad, California, United States
    Posts
    3,658
    Mentioned
    15 Post(s)
    Tagged
    0 Thread(s)
    I Pm'd you - thanks for having a look krityx! Have a good one!


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •