i created a gallery using bitmap Data. on my computer every thing works fine
when i upload it on the server it doesnt work properly on IE7 and 6 and on FF it works ok after i reload it a few times.....
what i have is a dynamic thumbnail strip which i load with an XML file. into a movieclip named thumbs in order to put a mask on it .
when i press one of the buttons the flash goes to that frame where i activate the next function:
Code:
var yLoc = 0;
var currentCatMain = 0;
loderFun = function (currentCat) {
	currentCatMain = currentCat;
	for (i=0; i<this["path_thNmame"+currentCat].length; i++) {
		this.createEmptyMovieClip("holder_mc"+i, this.getNextHighestDepth());
		this["loader"+i] = new MovieClipLoader();
		this["loader"+i].addListener(this);
		this["loader"+i].loadClip(this["path_thNmame"+currentCat][i], this["holder_mc"+i]);
	}
};
//this function is called by the 'loader' object when the file is loaded and ready to use
function onLoadInit(i) {
	m = i._name;
	m = m.slice(9, 10);
	this["myBitmap"+m] = new BitmapData(this["holder_mc"+m]._width, this["holder_mc"+m]._height, true, 0x00FFFFFF);
	this["myBitmap"+m].draw(this["holder_mc"+m]);
	this["holder_mc"+m].removeMovieClip();
	this.thumbs.createEmptyMovieClip("targetClip"+m, this.getNextHighestDepth());
	this.thumbs["targetClip"+m].attachBitmap(this["myBitmap"+m], 1);
	this.thumbs["targetClip"+m]._xscale = 100;
	this.thumbs["targetClip"+m]._yscale = 100;
	this.thumbs["targetClip"+m]._x = 0;
	this.thumbs["targetClip"+m]._y = yLoc;
	spaceAndWidth = this.thumbs["targetClip"+m]._height+4;
	yLoc += spaceAndWidth;
}
//this function is called by the 'loader' object if the file couldn't be loadd
function onLoadError() {
	/*
	
	    The external file failed to load so we don't need 
	    the holding movieclip anymore
	
	    */
	holder_mc.removeMovieClip();
}
what happens with the server is that i see each picture for a second and then it dissapears....

i have no idea why? here is the link