SitePoint Sponsor

User Tag List

Results 1 to 5 of 5
  1. #1
    SitePoint Zealot samohtwerdna's Avatar
    Join Date
    Jul 2007
    Posts
    151
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    using and interval on frame1 problem

    Hi,

    I am having problems with getting a function that is on frame1 with an interval to work for my movie clips not on frame1 (works fine for movie clips on frame1)

    why is this??

    do I need a special syntax??
    ie syntaxt for frame1 mc's:
    var colorInfo:ColorTransform=frame1_mc.tf_txt.transform.colorTransform;

    sytaxt for !frame1 mc's:
    var colorInfo:ColorTransform=(somethingSpecial).frame2_mc.lx_txt.transform.colorTransform;

    ??

    or am I not supposed to be able to have access to mc's on different frames?

  2. #2
    SitePoint Guru [Paul Ferrie]'s Avatar
    Join Date
    Oct 2007
    Location
    Glasgow, Scotland, UK
    Posts
    853
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    When triggering the function are you on the same frame as the movieclip you want to affect?
    .:To me AS is like LEGO, Only for the big Kids :.
    - Site - Blog - Glasgow Flasher
    bringmadeleinehome.com

  3. #3
    SitePoint Zealot samohtwerdna's Avatar
    Join Date
    Jul 2007
    Posts
    151
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Yes and no,

    I want to effect movie clips on three different frames - I need them to share the timer because the should transition at the same time as the menu_mc which is spans all the frames.

  4. #4
    SitePoint Guru [Paul Ferrie]'s Avatar
    Join Date
    Oct 2007
    Location
    Glasgow, Scotland, UK
    Posts
    853
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Can you post the fla and possibly comment areas i should be looking at.
    .:To me AS is like LEGO, Only for the big Kids :.
    - Site - Blog - Glasgow Flasher
    bringmadeleinehome.com

  5. #5
    SitePoint Zealot samohtwerdna's Avatar
    Join Date
    Jul 2007
    Posts
    151
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    the areas to look at are really the colorChange() function on frame 1 in Layer gactions -
    I have got it sort of working by using a conditional statement for the currentFrame but I still get a type error sometimes durring navagation and the flicker is really bothering me - I am at a complete loss as to how to approach fixing it.

    Thanks for your help!!!
    Attached Files Attached Files


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •