SitePoint Sponsor

User Tag List

Results 1 to 2 of 2
  1. #1
    SitePoint Enthusiast wyte raven's Avatar
    Join Date
    Feb 2007
    Location
    England, High Wycombe Bucks
    Posts
    76
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Accordion Example from Simply Javascript Book

    Hey!

    I've been following the simply javascript book and have recently completed the accordion example. I'm experiencing a major problem with this and I just can't figure out what it is thats happening - I'm guessing it has something to do with CSS positioning in IE7 or something, but I'm probably way off mark here.

    Note that I have downloaded and tested the files from the archive also, and these files do exactly the same thing - so it's not an error in my code. I won't supply any code examples, I'll assume that anyone that can help me, has run into the same problem, with these same files.

    The problem :-

    The accordion works absolutely fine in firefox, everything displays perfectly, the menu works great!

    However, in IE7 when I click on the menu heading to expand the content, it is revealed, but the two links contained within this content, aren't visible. However, if I then hover over another menu item (without clicking it to collapse the currently opened menu) the links then reappear within that currently opened content area as they should.

    Can anyone explain to me, why this script would function differently for these two browsers? I was under the impression that the script was made compatible with IE7

    Thank you in advance
    Wyte R@ven - Creator of the Rift

  2. #2
    SitePoint Enthusiast wyte raven's Avatar
    Join Date
    Feb 2007
    Location
    England, High Wycombe Bucks
    Posts
    76
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Ok, I have solved the problem with this issue.

    It was happening because I had also included the tooltips script in this html file. Although the both scripts worked perfectly in firefox together, in IE7 it seems to have caused all standard links in this html to disappear.

    I hope this helps anyone else with this problem should they also encounter it.
    Wyte R@ven - Creator of the Rift


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •