SitePoint Sponsor

User Tag List

Results 1 to 3 of 3
  1. #1
    SitePoint Member
    Join Date
    May 2008
    Posts
    14
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Zend_mail weird characters

    PHP Code:
    require_once 'Zend/Mail.php';
    $mail = new Zend_Mail();
    $mail->setBodyHtml(nl2br($_POST["comments"]));
    $mail->setFrom($_POST["youremail"], $_POST["yourname"]);
    $mail->addTo('me@gmail.com''company');
    $mail->setSubject('Website FeedBack');
    $mail->send(); 
    This is the output from my test
    This is a test
    =0D=0A
    =0D=0AThis is a test
    =0D=0A
    =0D= =0AThis is a test
    =0D=0A
    =0D=0AThis is a test
    I've read it has to with the mail function encoding \n\r, but I've got no idea how to solve this problem. I'm using the Zend framework 1.6.

  2. #2
    Strokin' Morango dele454's Avatar
    Join Date
    Oct 2005
    Location
    Cape town, South Africa
    Posts
    294
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Am using the ZF for an ongoing project. i think you are in the wrong place for any ZF related queries. Rather join this group - you will get a reply pronto- besides a lot of guys that worked on the ZF are very active in this forum.

    http://www.nabble.com/Zend-Framework...ty-f16154.html

    Good luck
    Last edited by dele454; Sep 22, 2008 at 06:18.

  3. #3
    SitePoint Member
    Join Date
    May 2008
    Posts
    14
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •