SitePoint Sponsor

User Tag List

Results 1 to 3 of 3
  1. #1
    SitePoint Member
    Join Date
    Sep 2008
    Posts
    2
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Question mcs set as invisible appear instead visible for a while

    Hi everyone
    I've four mcs on my root and I've set them as not visible except one.
    If I try the swf it works fine, but if I publish it, I see all of the four mcs for a while then the three tha have to be invisible disappear, why are they visible in the beginning?
    thx a lot

  2. #2
    SitePoint Guru [Paul Ferrie]'s Avatar
    Join Date
    Oct 2007
    Location
    Glasgow, Scotland, UK
    Posts
    853
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    How big is your is your swf? does this problem start when you upload and view the swf in the browser?
    .:To me AS is like LEGO, Only for the big Kids :.
    - Site - Blog - Glasgow Flasher
    bringmadeleinehome.com

  3. #3
    SitePoint Member
    Join Date
    Sep 2008
    Posts
    2
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Smile

    it's 3,46 kb
    it just only contains this four mc
    Perhaps I've solved the problem, setting the alpha = 0
    in the properties tab of each mc
    and then I switch beetween alpha = 0 e = 100 through the mc with hittest

    Now it works, but it sounds strange to me that I cannot use _visible in other ways, maybe setting *inside* each mc this._visible=false, so it could be faster...

    thx


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •