SitePoint Sponsor

User Tag List

Results 1 to 9 of 9
  1. #1
    SitePoint Enthusiast Cvent's Avatar
    Join Date
    Jul 2008
    Location
    McLean, VA
    Posts
    34
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Question Include Code Not Included

    I run a site which uses SSI for including common elements of code onto the page for easier maintenance.

    I noticed my pages aren't validating because of a missing closing paragraph tag </p> which is part of the include file.

    The </p> is the only part of the include not making it onto the page, so I'm puzzled as to why this is being omitted.

    The page is .shtml whereas the include uses .htm

    Here's the include code:
    HTML Code:
    <p class="links"><a href="../" title="Destination Guide City List">Back to Destination List</a><br /><a href="/" title="Cvent Homepage">Back to Cvent</a>
    Any thoughts?

    Thanks,
    Cvent

  2. #2
    SitePoint Enthusiast
    Join Date
    Nov 2007
    Posts
    50
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by Cvent View Post
    Here's the include code:
    HTML Code:
    <p class="links"><a href="../" title="Destination Guide City List">Back to Destination List</a><br /><a href="/" title="Cvent Homepage">Back to Cvent</a>
    If this is the include code, surely it should contain the closing </p> tag? Or am i missing something?

    J

  3. #3
    SitePoint Enthusiast Cvent's Avatar
    Join Date
    Jul 2008
    Location
    McLean, VA
    Posts
    34
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    If you follow the link you will see that the include file has the closing </p> tag but I suppose during the include process, it's getting stripped out.

  4. #4
    SitePoint Enthusiast Cvent's Avatar
    Join Date
    Jul 2008
    Location
    McLean, VA
    Posts
    34
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Any other thoughts, I cannot see why a </p> closing tag is disappearing...??

  5. #5
    SitePoint Enthusiast Cvent's Avatar
    Join Date
    Jul 2008
    Location
    McLean, VA
    Posts
    34
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    ^ Bump

  6. #6
    In memoriam gold trophysilver trophybronze trophy Dan Schulz's Avatar
    Join Date
    May 2006
    Location
    Aurora, Illinois
    Posts
    15,476
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    If you're referring to the links in the upper right hand corner, I can see them just fine in the page (right below "Search for Area Services").

  7. #7
    SitePoint Enthusiast Cvent's Avatar
    Join Date
    Jul 2008
    Location
    McLean, VA
    Posts
    34
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    The question is in regards to validation, I can't get it to validate, because part of the SSI isn't showing up (a </p> tag).

  8. #8
    In memoriam gold trophysilver trophybronze trophy Dan Schulz's Avatar
    Join Date
    May 2006
    Location
    Aurora, Illinois
    Posts
    15,476
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Try going through and fixing the 12 errors listed here one by one (re-checking for validation after each fix) and see if the problem clears up.

    http://validator.w3.org/check?uri=ht...Inline&group=0

  9. #9
    From space with love silver trophy
    SpacePhoenix's Avatar
    Join Date
    May 2007
    Location
    Poole, UK
    Posts
    5,014
    Mentioned
    103 Post(s)
    Tagged
    0 Thread(s)
    change that line you quoted to
    HTML Code:
    <p class="links"/><a href="../" title="Destination Guide City List">Back to Destination List</a><br /><a href="/" title="Cvent Homepage">Back to Cvent</a>
    then revalidate it, sometimes one mistake can cause a number of errors
    Community Team Advisor
    Forum Guidelines: Posting FAQ Signatures FAQ Self Promotion FAQ
    Help the Mods: What's Fluff? Report Fluff/Spam to a Moderator


Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •