SitePoint Sponsor

User Tag List

Results 1 to 2 of 2
  1. #1
    SitePoint Member
    Join Date
    Jan 2005
    Location
    USA
    Posts
    2
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Unhappy Error running 'rake test:units' from Simply Rails 2, Chapter 6

    I'm getting the following error when I run 'rake test:units' from Simply Rails 2, Chapter 6:

    Code:
    ksexton@vger:~/shovell$ rake test:units
    (in /home/ksexton/shovell)
    /usr/local/bin/ruby -Ilib:test "/usr/local/lib/ruby/gems/1.8/gems/rake-0.8.1/lib/rake/rake_test_loader.rb" "test/unit/story_test.rb"
    Loaded suite /usr/local/lib/ruby/gems/1.8/gems/rake-0.8.1/lib/rake/rake_test_loader
    Started
    EE
    Finished in 0.134564 seconds.
    
      1) Error:
    test_should_not_be_valid_without_name(StoryTest):
    ActiveRecord::StatementInvalid: SQLite3::SQLException: table stories has no column named name:  My shiny weblog link: INSERT INTO "stories" ("updated_at", "id", "name: My shiny weblog link", "created_at") VALUES ('2008-08-13 00:37:55', 953125641, 'poocs.net', '2008-08-13 00:37:55')
    I've tried recreating the databases, but that still doesn't fix the problem. Anyone have any ideas of things to test?

  2. #2
    SitePoint Member
    Join Date
    Aug 2008
    Posts
    14
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Not sure, but this can help:
    sitepoint . com/forums/showthread.php?t=558993


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •