SitePoint Sponsor

User Tag List

Results 1 to 4 of 4
  1. #1
    SitePoint Zealot DirtDiga's Avatar
    Join Date
    Jan 2002
    Location
    Belize City, Belize
    Posts
    114
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Linux and Apache

    Hi

    I'm not sure if this is the right forum for my question but here goes.

    I host my own server running Linux and Apache. I've never installed anything on a Unix system before. I'm trying to install Ikonboard forum software and have no idea how to verify that my system meets the recommended requirements.

    50mb Webspace
    Sendmail or SMTP to send emails
    Ability to run perl scripts as a CGI
    Perl version 5.6
    CGI.pm 2.4 or better
    DB_File installed (for DBM databse)

    Can someone guide me please. I'm new to Unix.

  2. #2
    ********* Callithumpian silver trophy freakysid's Avatar
    Join Date
    Jun 2000
    Location
    Sydney, Australia
    Posts
    3,798
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I don't know what CGI.pm is but otherwise, in general you would expect all the other requirements to be installed by default on most linux systems.

  3. #3
    SitePoint Wizard silver trophy Karl's Avatar
    Join Date
    Jul 1999
    Location
    Derbyshire, UK
    Posts
    4,411
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Most web hosts should have CGI.pm installed as it is a commonly used library. As for DB_File - you could run in to problems, its not that library might not be installed, its the fact that iKonboard is not well liked by web hosts, especially when its using DB_File as its database storage system. You would be much better off using the mySQL version of iKonboard.
    Karl Austin :: Profile :: KDA Web Services Ltd.
    Business Web Hosting :: Managed Dedicated Hosting
    Call 0800 542 9764 today and ask how we can help your business grow.

  4. #4
    SitePoint Member Artur's Avatar
    Join Date
    Apr 2002
    Location
    Chicagoland, USA
    Posts
    20
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    We run Ikonboard and it's a great forum. Easy to install and easy to manage. The only problem is that the latest version of Ikonboard is not stable.

    If you are going to use it, be sure you use version 3.0.1 and NOT 3.0.2 (I'm not sure about 3.0.3) but I've had terrible problems with 3.0.2.

    In any case, on a default install of RedHat you probably do not have the DBI/DBD drivers installed to run the board with MySQL, so you will need to run it on filesystem, which is fine unless you have a very busy forum.

    One thing though, if you have about $150 to spend on this project, you should probably use vBulletin. The fact that this forum, which is incredibly large, runs on it, is a testament to its stability and robustness.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •