SitePoint Sponsor

User Tag List

Results 1 to 6 of 6
  1. #1
    SitePoint Zealot
    Join Date
    May 2003
    Location
    Sarasota, FL
    Posts
    196
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Dude, where's my footer? (aka footer div missing in all but Firefox)

    See: http://bigfoot.shazamm.net/

    In Firefox 2 and 3 the footer shows up. In IE 7, Safari and Opera the footer is missing entirely. It's still there in the source code, it just doesn't display. The pages test as valid (aside from a few errors re: no type on tracking script tags). What gives? Any ideas?
    Chris Bloom
    Web Application Developer

  2. #2
    SitePoint Member
    Join Date
    Nov 2007
    Posts
    6
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    This is a shot in the dark 'coz I don't have time to investigate much.

    try adding or deleting </div> tags at the end and see what happens. It has happened to me before and I simply forgot to close a div or closed one too soon.

    I say this because it's the footer. Which makes me think something isn't complete.

    Hope that helps.

  3. #3
    SitePoint Zealot
    Join Date
    May 2003
    Location
    Sarasota, FL
    Posts
    196
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    The code validates as xhtml (other than some errors about absmiddle attributes), so there are no unclosed divs.
    Chris Bloom
    Web Application Developer

  4. #4
    The CSS Clinic is open silver trophybronze trophy
    Paul O'B's Avatar
    Join Date
    Jan 2003
    Location
    Hampshire UK
    Posts
    40,556
    Mentioned
    183 Post(s)
    Tagged
    6 Thread(s)
    Have you fixed this ?

    The footer seems to be there in Ie7/Opera or am I looking at the wrong thing

  5. #5
    SitePoint Zealot
    Join Date
    May 2003
    Location
    Sarasota, FL
    Posts
    196
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    OK, that's really bizarre. I didn't make any fixes for that, but you are correct - it is now appearing in IE, Safari and Opera, or at least on the test site. It's still missing on the production so it must have been fixed by some other change I was working on. Meanwhile I was still looking at prod for remaining issues... Sorry for the confusion, but thanks for taking a look
    Chris Bloom
    Web Application Developer

  6. #6
    The CSS Clinic is open silver trophybronze trophy
    Paul O'B's Avatar
    Join Date
    Jan 2003
    Location
    Hampshire UK
    Posts
    40,556
    Mentioned
    183 Post(s)
    Tagged
    6 Thread(s)
    You're welcome


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •