SitePoint Sponsor

User Tag List

Results 1 to 4 of 4
  1. #1
    SitePoint Member
    Join Date
    Mar 2008
    Posts
    24
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Question Center flash swf in table

    Hi all, I realize it seems like a simple thing to center a flash movie on a page, but for some reason this swf is not wanting to cooperate with me.

    Here is the web address: http://www.lcca.com/gt

    You will see that the flash movie is 768 wide and the table is 769 I think. I just want it to span from white edge to white edge, but it stretches the table out and aligns left. I've tried everything - putting it in it's own table, aligning the tds, all the css tricks, but it just won't move.

    I'm probably missing something simple here, but I can't figure it out. Any help is greatly appreciated.

    Thanks!

  2. #2
    SitePoint Member
    Join Date
    Mar 2008
    Posts
    24
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Can anybody offer any insight?

    I'll keep trying to figure it out on my own...maybe I'll come up with something.

  3. #3
    SitePoint Zealot ejg's Avatar
    Join Date
    Jun 2007
    Posts
    141
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    As this is the css forum, I will throw out the first "get rid of the tables and use css properly" comment.

    Truly, I don't think there is a way css can center your flash.

    The problem has to do with your table layout. Tables expect to have X rows by Y columns with every row having the same number of columns.

    Your Table_03 has
    row1 : 1 column (this is the flash)
    row2 : 2 columns
    row3 : 3 columns
    row4 : 2 columns
    row5 : 9 columns

    Row1 is expanding the first column to the width of the flash but it is not the width of the whole table because it is reserving space for the other 8 columns that are defined in row5. I don't know if you can save this design with colspan or not. You may have better luck asking your question in the HTML forum.

  4. #4
    SitePoint Member
    Join Date
    Mar 2008
    Posts
    24
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks ejg...I didn't realize I made such a "newbish" mistake. I'll take a look at the columns and try to sort it out - and if not try the HTML forum.

    Thanks again!


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •