SitePoint Sponsor

User Tag List

Results 1 to 3 of 3
  1. #1
    SitePoint Enthusiast ehsen's Avatar
    Join Date
    Jun 2005
    Posts
    75
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Internet Explorer CSS Problem

    I am designing a wordpress theme (this is my first theme). My design doesn't show correctly in IE.

    Here is the design in Firefox (in which sidebar is showing up properly)



    Here is the Design in Internet Explorer.



    CSS code for footer & innersidebar (the white area in sidebar)

    Code:
    #footer {
    float:left;
    width:800px;
    clear:both;
    font-weight:bold;
    color:#FFFFFF;
    background:#000000;
    height:20px;
    text-align:center;
    }
    
    .innersidebar {
    float:right;
    width:180px;
    margin-right:15px;
    background-color:#FFFFFF;
    color:#FF0000;
    }
    Would you please advise me how can I fix this problem.

  2. #2
    SitePoint Wizard bronze trophy Tyssen's Avatar
    Join Date
    Oct 2005
    Location
    Brisbane, QLD
    Posts
    4,067
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Your footer's obviously not clearing the floats properly but you haven't provided enough code to be able to give you an accurate answer. You don't need to float #footer though.

  3. #3
    SitePoint Enthusiast ehsen's Avatar
    Join Date
    Jun 2005
    Posts
    75
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I fixed it. Actually my XHTML code was the culprit. I validate my code and fixed all errors and bingo my theme is working perfectly.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •