SitePoint Sponsor

User Tag List

Results 1 to 5 of 5

Hybrid View

  1. #1
    SitePoint Enthusiast Alijawaad's Avatar
    Join Date
    May 2008
    Posts
    75
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    I messed up my wp permalink structure...404 errors everywhere

    I just changed my permalink structure in wordpress from the default "p=1" structure to one that uses the title of each post.
    After changing it....i get a message that I should update my htaccess file.
    I dont know what htaccess is....but now when i try clicking on any link...i get a 404 error...
    please help...

  2. #2
    Function Curry'er JimmyP's Avatar
    Join Date
    Aug 2007
    Location
    Brighton, UK
    Posts
    2,006
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    What did you change the permalink structure to?
    James Padolsey
    末末末末末末末末末末末末末末末末末末末
    Awesome JavaScript Zoomer (demo here)
    'Ajaxy' - Ajax integration solution (demo here)

  3. #3
    SitePoint Enthusiast Alijawaad's Avatar
    Join Date
    May 2008
    Posts
    75
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I changed it to /%postname%/

  4. #4
    SitePoint Enthusiast Alijawaad's Avatar
    Join Date
    May 2008
    Posts
    75
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    ok...wordpress tells me to put this into my htaccess file..
    how do i edit htaccess?

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /wordpress/
    RewriteCond &#37;{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /wordpress/index.php [L]
    </IfModule>

  5. #5
    SitePoint Enthusiast Alijawaad's Avatar
    Join Date
    May 2008
    Posts
    75
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    problem solved...i used filezilla to edit htaccess and everything works fine now..thanks!


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •