SitePoint Sponsor

User Tag List

Results 1 to 4 of 4
  1. #1
    SitePoint Zealot
    Join Date
    May 2007
    Posts
    126
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Firefox Problem with repeating divs Urgent

    Hi all,

    I seem to be having a problem in Firefox only seems fine in IE.

    What I have is a div container with divs inside, the div container is with php and database to display a list of products but for some reason the divs seem to mess up in random places and become scatter accross the page does anyone know why this is???

    I thought it may have just beeen a one off but its been happening sometime and I have just found another site I created that is doing the same thing.

    Could some please help me out here I cant figure out what the problem is.

    Here are the two links but it happens on random product pages where the php is replicating a large list of divs when there are on a few products it doesn't seem to happen.

    Site 1: http://www.locksandfittings.co.uk/products/subcat/7

    Site: 2: http://www.srsclubshop.co.uk/cgi/pro...rmance&catID=2

    Thank you all for your help in advance

  2. #2
    SitePoint Guru alecrust's Avatar
    Join Date
    Jun 2007
    Location
    London, UK
    Posts
    728
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Looks fine for me in Firefox 3. Here's a screenshot.
    Honda Civic Forum - UK Civic Forum
    Web Host Reviews - Independent, honest host reviews
    My Portfolio - Simplicity is the ultimate sophistication

  3. #3
    SitePoint Author silver trophybronze trophy

    Join Date
    Nov 2004
    Location
    Ankh-Morpork
    Posts
    12,159
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    The second one looks fine in Opera 9.5.

    In the first one, the labels and form controls are mismatched. That's probably because of the very odd mixture of units, like using em-sized labels inside a px-sized div. The slightest difference in font size calculations will make the content wrap in the wrong place, which seems to be what happens here.
    Birnam wood is come to Dunsinane

  4. #4
    SitePoint Zealot
    Join Date
    May 2007
    Posts
    126
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hi

    I have tried firefox and it still is doing the same thing.
    Also I have changed all the font sizes and labels from em to pixels so it is consistent and it is not fixing the problem.

    In the quick search field in the header type locks and click search. You will then see the search result divs not laying out correctly. If you click refresh a couple of times the divs appear correctly does anyone know how to fix this?


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •