SitePoint Sponsor

User Tag List

Results 1 to 3 of 3
  1. #1
    SitePoint Addict ornette's Avatar
    Join Date
    Mar 2005
    Location
    Tenerife, Canary Isles
    Posts
    175
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Difficulty with IE Conditional Comments

    Hello there,
    I've got this site working well in all browsers except IE6. I put a conditional comment for IE but that seemed to put IE7 out. Now I have made it to address IE6 only, but it doesn't work! The positioning of the text is far too far to the left.
    There must be something simple that I can't see after staring at it for so long. Can anyone help me to get the CC to work? Please.
    Thanks
    http://www.frank.uk.com/html/pages/i...dex_drink.html

  2. #2
    SitePoint Zealot
    Join Date
    Feb 2007
    Posts
    100
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    You dont have a space between "IE" and "6" so it should look like...

    <!--[if IE 6]>
    Special instructions for IE 6 here
    <![endif]-->

    Try that and see if it sorts out the problem.

  3. #3
    SitePoint Addict ornette's Avatar
    Join Date
    Mar 2005
    Location
    Tenerife, Canary Isles
    Posts
    175
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Duh,
    Maybe I should go to bed earlier, or take more breaks. Yes, it all works fine now. Thanks for spotting it. Apart from the really difficult problems, for which it is a tremendous help, this forum is brilliant at spotting that silly mistake that has you tearing your hair out...just like this one.
    Thanks jonpenny and thanks to all who help keep us sane!


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •