SitePoint Sponsor

User Tag List

Results 1 to 4 of 4
  1. #1
    SitePoint Addict Mr Jojo's Avatar
    Join Date
    May 2007
    Posts
    322
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    WAMP and PROXIES

    I have wamp installed, but when i run functions in PHP that need to access the internet like fopen() apache uses my normal internet connection.

    I want that apache connects to the internet through localhost:8118 instead.

    How can i configure apache to connect using localhost:8118 (my proxy)?

    Note: I'm not talking about the URL i use to access www/ folder content, i'm talking the port that apache uses to access to the internet to fetch data with PHP functions like fopen().

  2. #2
    Certified Ethical Hacker silver trophybronze trophy dklynn's Avatar
    Join Date
    Feb 2002
    Location
    Auckland
    Posts
    14,645
    Mentioned
    19 Post(s)
    Tagged
    3 Thread(s)
    Jo,

    Then you've got to use :8118 in your links.

    Regards,

    DK
    David K. Lynn - Data Koncepts is a long-time WebHostingBuzz (US/UK)
    Client and (unpaid) WHB Ambassador
    mod_rewrite Tutorial Article (setup, config, test & write
    mod_rewrite regex w/sample code) and Code Generator

  3. #3
    SitePoint Member
    Join Date
    Jun 2008
    Posts
    1
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    You'll probably have to
    modify Apache settings in the httpd.conf file

  4. #4
    SitePoint Member
    Join Date
    Sep 2006
    Posts
    15
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I think, php can not tunnel connections through a proxy automatically for fopen. You need to use something like cURL functions to use a local proxy.
    Acio! Proxy Script
    Now with auto myspace friend adder and bulletin poster.
    Supports Youtube, MySpace and Gmail, GeoIP, Antihotlinking,
    URL Encryption and More.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •