SitePoint Sponsor

User Tag List

Results 1 to 2 of 2
  1. #1
    SitePoint Member
    Join Date
    Jun 2008
    Posts
    1
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    script/server error wants gem 0.9.4, I have 1.1.1

    Ubuntu 7.04, Ruby 1.8.6, Gems 1.1.1, Rails 2.1.0, sqlite3 3.5.9

    created app shovell

    inside shovell ran script/server:

    Rails requires RubyGems >= 0.9.4. Please install RubyGems and try again: rubygems.rubyforge.org


    Where is this error coming from? I have Gems 1.1.1

    Thanks,
    Anteaya.

  2. #2
    SitePoint Enthusiast
    Join Date
    May 2008
    Posts
    43
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    try these:

    Code:
    gem update --system #for gems 0.8.X or lower
    gem update #for 0.9.0 or newer.
    also try
    Code:
    gem env
    make sure the gem version is the one you've listed.

    in addition i would do these:
    Code:
    %gem cleanup
    %sudo gem update


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •