SitePoint Sponsor

User Tag List

Results 1 to 4 of 4
  1. #1
    SitePoint Addict blizzman24's Avatar
    Join Date
    Jul 2004
    Location
    Texas
    Posts
    345
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Help with creating a tracking pixel

    I'm trying to create a pixel that tracks whenever someone enters the thank you page after the transaction. My pixel looks like this..

    <img src="http://www.mysitehere.com/pixel.php" width="1" height="1" />

    I put that at the bottom of my page and it should call the script at pixel.php, but for some reason it's not working. I think it may be because https prevents it from sending the info. It works when I test it on just http urls. Any ideas?

  2. #2
    Team SitePoint santouras's Avatar
    Join Date
    Jul 2006
    Location
    planet earth
    Posts
    276
    Mentioned
    16 Post(s)
    Tagged
    0 Thread(s)
    is this on an external site? ie. is your tracking pixel code on a site different to the one you're processing the transaction on? If it isn't, do a link to it without the http://www.mysitehere.com portion. If it is on a seperate site, you're going to have to purchase an ssl certificate for your tracking site. Browsers will display a broken lock if they need to use any elements that are sourced from a non https location. IE will also pop up a warning asking if the user would like to display the non-secure elements. If the user selects no, they won't get your tracking image.
    my utility belt tells me its to the bar batman

    read the manual then google it then do a search THEN post....

  3. #3
    Sesame Street Iimitk's Avatar
    Join Date
    Feb 2006
    Posts
    662
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Why not use <input type="hidden"...>?
    Imagination is more important than knowledge. - Einstein

  4. #4
    SitePoint Addict blizzman24's Avatar
    Join Date
    Jul 2004
    Location
    Texas
    Posts
    345
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by simsim View Post
    Why not use <input type="hidden"...>?
    isn't input type just for forms? I did a search and that's all that came up. and yes, the pixel is located off site.

    edit: I think I see what you're saying but the <input type="hidden" ..> doesn't fire off the script. <input type="image"...> does though... not sure if it will work off site yet.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •