SitePoint Sponsor

User Tag List

Results 1 to 2 of 2
  1. #1
    SitePoint Enthusiast
    Join Date
    Apr 2008
    Location
    Glasgow, west coast of Scotland
    Posts
    27
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Securing XAMPP has disabled localhosted Wordpress- help needed please

    Hello.

    I'd welcome a little advice.

    I have installed Wordpress on my localhost using XAMPP.

    I was able to log in to my Admin.

    In order to make XAMPP more secure, I followed the instructions at the bottom of this message.

    I now cannot access Wordpress as it says: "Error establishing database connection".

    I know that trying to make XAMPP secure has disabled Wordpress, but I am not sure how or why.

    Could someone please advise me how I can enable access to Wordpress on my localhost?

    Is there a way to make XAMPP secure AND enable Wordpress on my localhost?

    Thank you in advance.

    BG




    <strong>
    PROCEDURE FOLLOWED</strong>

    Start Apache and MySQL and go to http://localhost in your browser (on the same machine as your server). If this is your first time browsing the local site, you should now see a webpage with the XAMPP logo and a choice of languages. Click on your preferred language.

    This brings you to an XAMPP control page with navigation links in the left sidebar. Click on “Security”. The page may take a moment to load, it is checking your security status. After it loads, you will see various states of your security status and how your server is currently insecure.

    To fix the first 3 problems listed on this page (XAMPP pages publicly accessible, mySQL has no password, and phpMyAdmin is freely accessible), scroll down until you see this link: http://localhost/security/xamppsecurity.php. Click on that link. If you don’t have that link, click here to bring you to that page on your local server.

    You’ll now see a page titled “Security console MySQL & XAMPP directory protection”. Do the following:

    1. Enter a password (2 times) for the MySQL SuperUser (root)
    2. Select “cookie” for “PhpMyAdmin authentification” (this is the default, and I prefer it over http authentification).
    3. Do not check “Safe plain password in text file?”
    4. Record this password in a safe place so you don’t forget it.
    5. Click the button “Password changing”.

    If done correctly, you should get this message “The root password was successfully changed. Please restart MYSQL for loading these changes!”. Go ahead and restart MySQL via the XAMPP control panel (stop it and then start it again).

    Now, back on the XAMPP security page, scroll down to “XAMPP DIRECTORY PROTECTION (.htaccess)”. Do the following:

    1. Enter a username.
    2. Enter a password.
    3. Leave unchecked “Safe plain password in text file? “
    4. Record the username/password in a safe place so you don’t forget it.
    5. Click the button “Make safe the XAMPP directory”

    Check that it was successful by looking above the “XAMPP DIRECTORY PROTECTION (.htaccess)” for this message: “SUCCESS: The XAMPP directory is protected now! All personal data was safed in the following file: C:\xampp\security\xampp.users C:\xampp\htdocs\xampp\.htaccess”.

    In the future, you can use this page again to change your MySql password, but I don’t recommend using it for your XAMPP password since it will erase any users that you may have added for XAMPP access. If you are the only user for the XAMPP pages, then it is ok to use this form to enter a new password.

    You can relaunch the security page to see what XAMPP thinks of your security now. To do this, click on “Security” in the left sidebar. The top 3 items should indicate “Secure” now. If not, you have an issue.

  2. #2
    whagwan? silver trophybronze trophy akritic's Avatar
    Join Date
    Nov 2006
    Posts
    2,780
    Mentioned
    1 Post(s)
    Tagged
    1 Thread(s)
    I followed that exact same proceedure when using XAMPP previously and didn't have a problem.

    Have you tried repeating the install from scratch? Maybe there was something you missed.

    Also have you checked in the CP that MySQL is actually running?


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •