SitePoint Sponsor

User Tag List

Results 1 to 4 of 4
  1. #1
    SitePoint Addict
    Join Date
    May 2006
    Posts
    250
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Lightwindow not working in IE

    Hi all, not sure if anyone is familiar with lightwindow? I'm using it for my image gallery and IE6 and 7 isn't playing along at all, its fine in FF and Sarafi In IE I get an error that says...

    Code:
    Line: 444
    Char: 4
    Error: Object doesn’t support this property or method
    Code: 0
    URL: http://weirbar.pmhclients.com/gallery/index-lightwindow
    the error goes away if i remove the lightwindow.js inclusion, but… well that defeats the entire purpose.

    Any ideas? I've posted on the forum but still waiting for a response.

    here is the link

    Thanks
    Last edited by mikeebee8; Apr 21, 2008 at 07:17.

  2. #2
    SitePoint Wizard gRoberts's Avatar
    Join Date
    Oct 2004
    Location
    Birtley, UK
    Posts
    2,439
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    For an unknown reason, the following code from the lightwindow.js line 933 is causing an exception:

    Code:
    _getGalleryInfo : function(rel) {
            if (!rel) return false;
            if (rel.indexOf('[') > -1) {
                return new Array(escape(rel.substring(0, rel.indexOf('['))), escape(rel.substring(rel.indexOf('[')+1, rel.indexOf(']'))));
            } else {
                return false;
            }
        }
    Although, it seems to work perfectly fine if I manually use the code

    Code:
    return new Array(escape(rel.substring(0, rel.indexOf('['))), escape(rel.substring(rel.indexOf('[')+1, rel.indexOf(']'))));
    on its own.

    it may be worth asking the owner of the code to take a look!


  3. #3
    SitePoint Addict
    Join Date
    May 2006
    Posts
    250
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks Gavin, I have emailed the guy but just thought I'd check here see if it was anything obvious

  4. #4
    SitePoint Member
    Join Date
    Aug 2008
    Posts
    2
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hello, try putting the scripts in the <head> tag in this order. It helped me out.

    1) prototype.js
    2) scriptaculous.js?load=effects
    3) lightwindow.js

    Hope this helps

    Pockitz


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •