SitePoint Sponsor

User Tag List

Results 1 to 6 of 6
  1. #1
    SitePoint Zealot
    Join Date
    Aug 2007
    Location
    Toronto
    Posts
    184
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Strange 302 error when validating

    Hi everyone,

    I've had nothing to do with this website, but I was asked to see why the page is not recognized by the W3C validator:

    http://www.theroseplaceflowers.com/

    The error on w3c says:

    I got the following unexpected response when trying to retrieve <http://www.theroseplaceflowers.com/>:

    302
    A google search does not seem to find much on this particular error in relation to w3c validation. It seems something in the HTML code is stopping the validator, or else something on the server. And I'm aware that the page can be validated by direct input after a 'view source' but I was just wondering why this particular problem was occurring.

    Anyone have any ideas on this?

    Thanks,

    Louis.

  2. #2
    SitePoint Author silver trophybronze trophy

    Join Date
    Nov 2004
    Location
    Ankh-Morpork
    Posts
    12,159
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    302 is a temporary redirect. Try specifying the actual page, rather than the site, i.e., http://www.theroseplaceflowers.com/index.php.

    You've got three errors on that page:
    • Two meta elements with invalid pretend-XHTML syntax. Change the '/>' into '>' for both elements.
    • A missing alt attribute for an image.
    Birnam wood is come to Dunsinane

  3. #3
    SitePoint Zealot
    Join Date
    Aug 2007
    Location
    Toronto
    Posts
    184
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Nope, I'm still getting the same 302 error when I try to use a direct page link, as you mentioned. Strange.

  4. #4
    SitePoint Author silver trophybronze trophy

    Join Date
    Nov 2004
    Location
    Ankh-Morpork
    Posts
    12,159
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Yeah, for some reason it does send a 302. These are the headers your server responds with for a request to index.php,
    Code:
    HTTP/1.1 302
    Date: Tue, 01 Apr 2008 16:04:09 GMT
    Server: Apache
    Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0
    Expires: Thu, 19 Nov 1981 08:52:00 GMT
    Pragma: no-cache
    X-Powered-By: PHP/4.4.1
    Set-Cookie: PHPSESSID=a56796e2939267a103cff7ef9a26c63d; path=/
    Location: index.php
    Connection: close
    Content-Type: text/html
    Birnam wood is come to Dunsinane

  5. #5
    SitePoint Zealot
    Join Date
    Aug 2007
    Location
    Toronto
    Posts
    184
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Okay thanks, that info helped us track down the issue. The page was (for no apparent reason) redirecting to itself. Probably to ensure a cookie was created, or something. Removing the redirect solves the problem.

    BTW, my copy of The Ultimate CSS Reference arrived yesterday. Can't wait to crack it open.

    Louis.

  6. #6
    SitePoint Author silver trophybronze trophy

    Join Date
    Nov 2004
    Location
    Ankh-Morpork
    Posts
    12,159
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I'm glad to hear you found a solution. Thanks for telling us!

    And I hope you'll find the book useful.
    Birnam wood is come to Dunsinane


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •