SitePoint Sponsor

User Tag List

Results 1 to 2 of 2
  1. #1
    SitePoint Member
    Join Date
    Mar 2008
    Posts
    6
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Prototype class.create issue with IE

    Hello,

    I'm working with Prototype and have created a class using Class.create. The class works perfectly on Firefox (of course) but IE7 reports an error on the first line which is:

    var catalog = Class.create({

    I've also just tried catalog = Class.create({

    and get the same results. I'm refactoring some non-class based code into a class and the non-class based code worked fine in both browsers.

    I'm thinking that there's just some simple oversight on my part since it's a syntax error, but I'm at a loss for what that error is. Any help would be appreciated.
    Last edited by MikeFeltman; Mar 7, 2008 at 22:31.

  2. #2
    SitePoint Member
    Join Date
    Mar 2008
    Posts
    6
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Nevermind. I started pasting the code bit by bit into a new file and kept testing the page after each paste, referencing the new file and eventually, the whole thing was pasted in and functioned properly in both IE and Firefox. The only thing I can think of was that there was some high ASCII character in the original script that IE barfed on and Firefox handled.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •