SitePoint Sponsor

User Tag List

Results 1 to 2 of 2
  1. #1
    SitePoint Member
    Join Date
    Jun 2001
    Location
    Sault Ste. Marie
    Posts
    15
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Weird Browser Problems and PHP Class

    I wrote a php class that is used to validate forms.

    Basically the class checks for required fields, checks field data with a regexp and gathers appropriate errors then sends the error messages to the user.

    It displays the errors and asks them to hit the back button to correct the problem.

    You can see it in action here
    http://www.blc-grmi.org/hill_child/contact.php

    The code is here
    http://www.blc-grmi.org/common/php/c...tionObject.txt

    My problem is this,
    Internet Explorer 6 is sending the error page twice which causes the browser to lose the form information page altogether (check above url ../contact.php)

    This doesn't happen in any netscape versions or with IE on my IIS server at home so i'm lost--i have no idea if this a browser problem or a problem in the way i wrote my script or a server problem.

    Help please.

  2. #2
    SitePoint Wizard silver trophy redemption's Avatar
    Join Date
    Sep 2001
    Location
    Singapore
    Posts
    5,269
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    woah too much code to read ...

    without having read thru your code, i can say that it'd be friendlier to your users if you re-displayed the form with the error messages instead of asking them to press the back button...

    it'd also be easier to ensure the fields already filled in persist too...


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •