SitePoint Sponsor

User Tag List

Results 1 to 3 of 3
  1. #1
    SitePoint Addict
    Join Date
    Jul 2004
    Location
    CA
    Posts
    295
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Tabs line up in Firefox but not in IE

    I hate IE. I added an AJAX content tabs to my site and it looks great in firefox. In IE6, the tabs do not line up properly above the content.





    When I try to adjust the default CSS settings for IE6, it messes up firefox. I'm at my wits end. I'm sure it has something to do with an IE6 bug, but I'm not sure.

    The site is at http://www.filipina-lady.org -- look at in firefox and all is good -- look at it in IE and all is not right.

    Below is the css code:

    .shadetabs{
    padding: 3px 0;
    margin-left: 0;
    margin-top: 1px;
    margin-bottom: 0;
    font: bold 12px Verdana;
    list-style-type: none;
    text-align: left; /*set to left, center, or right to align the menu as desired*/
    }

    .shadetabs li{
    display: inline;
    margin: 0;
    }

    .shadetabs li a{
    text-decoration: none;
    position: relative;
    z-index: 1;
    padding: 3px 7px;
    margin-right: 3px;
    border: 1px solid #778;
    color: #2d2b2b;
    background: white url(shadeactive.gif) top left repeat-x;
    }

    .shadetabs li a:visited{
    color: #2d2b2b;
    text-decoration: none;
    }

    .shadetabs li a:hover{
    text-decoration: none;
    color: red;
    text-decoration: none;
    }

    .shadetabs li a.selected{ /*selected main tab style */
    position: relative;
    top: 1px;
    }

    Any help in how to make it look in IE like it does in Firefox would be appreciated.

    Thanks

  2. #2
    SitePoint Enthusiast LadynRed's Avatar
    Join Date
    Sep 2003
    Location
    TN
    Posts
    37
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Well, for one thing you have a div and a list INSIDE an <h3> header - that's not proper. I suspect you forgot to add the closing </h3> tag.

    I suggest you fix that first, then see what's happening.

  3. #3
    SitePoint Addict
    Join Date
    Jul 2004
    Location
    CA
    Posts
    295
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks LadyinRed for your input. It took me a while, but I believe I accomplished the task and now it lines up properly in both IE6 and Firefox (I don't have IE7 yet).

    My only minor problem is in IE text decoration none is ignored. Links are underlined in IE and in firefox they are not. Searched the net, but no luck

    For example if you look at it in IE and click the Registration tab, you will see Filipina Lady Dating underline, but like I said, I have text-decoration: none and it still displays. I'm puzzled why. Do you have a clue?

    Thanks again


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •