SitePoint Sponsor

User Tag List

Results 1 to 6 of 6
  1. #1
    SitePoint Addict
    Join Date
    Jun 2007
    Location
    Sydney, Australia
    Posts
    253
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Lightbulb IE6 bugs and page side borders

    Hey, the site is at link

    These are my problems:

    1. In IE6, the "contact" item in the nav, falls into the next line.

    2. The coloumns in the content are stuffed in IE6

    3. How do I add borders to the sides of the page? I want to add aleft border and a right border
    They are PNG-24 files.

    Thanks everyone.

  2. #2
    SitePoint Addict
    Join Date
    Feb 2006
    Posts
    247
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    FF and IE work with margin, padding and borders differently. Example. Setting a padding in FF will actually stretch a div, but not in IE. However, in IE you can add a border to an inner div and the div will stay contained. Not in FF.

    By looking at your site, I'm assuming IE is reading your Navigation buttons differently than FF.

    I can't give a clear answer for you, but you should fiddle with your margins, padding and borders.
    I live in Madison. Where in the W1RLD do you live?

  3. #3
    Design Your Site Team bronze trophy Erik J's Avatar
    Join Date
    May 2007
    Location
    Countryside, Sweden
    Posts
    3,407
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    1. Viewing the css-source in IE6 I see a specificity issue:
    The later "#contact" cannot overrule "#nav li", the id+element gives higher specificity, and the border does not get "none".
    But with element added; "li#contact" would overrule as it comes later.
    Happy ADD/ADHD with Asperger's

  4. #4
    Design Your Site Team bronze trophy Erik J's Avatar
    Join Date
    May 2007
    Location
    Countryside, Sweden
    Posts
    3,407
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    2. It is the Double Margin Bug in action.

    Bug-fix; add "display: inline" to the #main declaration.
    Happy ADD/ADHD with Asperger's

  5. #5
    SitePoint Addict
    Join Date
    Jun 2007
    Location
    Sydney, Australia
    Posts
    253
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    1. Thanks erik, the only problem now is that in IE6 the #nav's border-bottom is not showing. EDIT: I fixed that by placing all the border properties in #nav li.

    2. Thanks erik, it works now, btw I had to add display: inline; to both the #main and the #sub.

    Problems 1 and 2 down, now just the hard one is left

    Thanks guys
    Last edited by znebojsa; Feb 9, 2008 at 16:10.

  6. #6
    SitePoint Addict
    Join Date
    Jun 2007
    Location
    Sydney, Australia
    Posts
    253
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I realise that there are two seperate issues at hand:

    1. Positioning the shadows/borders

    2. Alpha transparency support in IE.

    Well I need to conquor both issues, but 1. is more important atm.

    Thanks


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •