SitePoint Sponsor

User Tag List

Results 1 to 6 of 6
  1. #1
    SitePoint Addict
    Join Date
    Jun 2007
    Location
    Sydney, Australia
    Posts
    253
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    IE6 hover problem

    Got what i needed, thanks
    Last edited by znebojsa; Feb 8, 2008 at 22:53.

  2. #2
    SitePoint Member Niki Liu's Avatar
    Join Date
    Apr 2007
    Posts
    24
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I can't seem to replicate your hover problem, but to fix your cursor issue, adding something like...

    Code:
    a { cursor: pointer; }
    ...should fix that.
    Niki

  3. #3
    SitePoint Addict
    Join Date
    Jun 2007
    Location
    Sydney, Australia
    Posts
    253
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    that fixed that problem, thanks

  4. #4
    SitePoint Addict
    Join Date
    Jun 2007
    Location
    Sydney, Australia
    Posts
    253
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    so can no one replicate my hover issue? It has happened to me on 3 different IE6 computers that I tried, the hover image doesn't vanish after the mouse moves away

  5. #5
    Design Your Site Team bronze trophy Erik J's Avatar
    Join Date
    May 2007
    Location
    Countryside, Sweden
    Posts
    3,407
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by znebojsa View Post
    so can no one replicate my hover issue? It has happened to me on 3 different IE6 computers that I tried, the hover image doesn't vanish after the mouse moves away
    I can't replicate that behavior on IE5-6 either.

    Curious, why are you using spans for the bg-images? Instead of e.g. like:
    Code CSS:
    #what{
    	position: absolute;
    	top: 75px;
    	left: 30px;
    }
    #what a{
    	display: block;
    	width: 181px;
    	height: 40px;
    	background: url(what.jpg) no-repeat;
    	text-indent: -9999px;
    }
    #what a:hover{
    	background-position: 0 -40px;
    }
    Happy ADD/ADHD with Asperger's

  6. #6
    The CSS Clinic is open silver trophybronze trophy
    Paul O'B's Avatar
    Join Date
    Jan 2003
    Location
    Hampshire UK
    Posts
    40,556
    Mentioned
    183 Post(s)
    Tagged
    6 Thread(s)
    Curious, why are you using spans for the bg-images? Instead of e.g. like:
    Its an image replacement technique (possibly the best type as it works in images off, or css off, or both off situations)

    Quote Originally Posted by znebojsa
    so can no one replicate my hover issue?
    I couldn't replicate it either but the usual fix when the hover state sticks is this:

    Code:
    #what a:hover{visibility:visible}

    Hope it helps


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •