SitePoint Sponsor

User Tag List

Results 1 to 6 of 6

Threaded View

  1. #1
    SitePoint Guru
    Join Date
    Mar 2004
    Posts
    639
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Script works fine in Firefox, but doesn't work in IE. No error messages.

    Hello guys,

    I have a script, which is works fine in Firefox, but doesn't work in IE. I get no any error messages in IE.

    The problem is when I click links (script calls function that loads some HTML with Ajax), nothing happens in IE. In Firefox script loads photos...

    The Ajax code is standard:

    var AJAXshowPhotos = null;
    if (window.XMLHttpRequest) { AJAXshowPhotos=new XMLHttpRequest(); }else{ AJAXshowPhotos=new ActiveXObject("Microsoft.XMLHTTP"); }

    AJAXshowPhotos.onreadystatechange = function() {
    if (AJAXshowPhotos.readyState==4 || AJAXshowPhotos.readyState=="complete"){
    document.getElementById('photoBox').innerHTML = AJAXshowPhotos.responseText;
    }
    }
    I've checked code like 20 times and everything should work fine. I'm really confused by this.

    Can you look at the sample on this page please (click on "Photo albums", then "Aphrodite's Rock", "Limassol Zoo" that do not work).

    Function that called after user clikcs those links is showPhotoByAlbum();
    Last edited by al9; Jan 31, 2008 at 14:38.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •