SitePoint Sponsor

User Tag List

Results 1 to 2 of 2

Hybrid View

  1. #1
    SitePoint Member
    Join Date
    Mar 2002
    Posts
    5
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Replication error on mysql

    Hi everyone,
    Got some question for you.Im tyring to replicate a mysql database to another server.They are both running RedHat linuux 7.1,php-4.1.1 x 7.1, apache_1.3.20,mod_ssl-2.8.4-1.3.20,oracle 8.0.5,and
    mysql-3.23.49.

    fyi:
    ip for both server is x.x.20.221 and x.x.20.223
    I also created the user 'rep' and granted access to server from any host

    GRANT FILE ON *.* TO rep@"%" IDENTIFIED BY 'rep123';


    I added the following code to my master server my.cnf file
    -------------------------------------------------
    [mysql]
    log-bin
    server-id= 221
    --------------------------------------------------
    and for the slave server i added this to its my.cnf file

    --------------------------------------------------
    [mysql]
    master-host =192.168.20.221
    master-user=rep
    master-password=rep123
    master-port=3306
    server-id=223
    ----------------------------------------------------
    but when i restarted both server i got this error at slave err log


    _errno 0,server_errno=65535)
    020313 9:16:15 Slave: Failed reading log event, reconnecting to retry, log 'FIRST' position 28
    020313 9:16:15 Slave: reconnected to master 'rep@192.168.20.221:3306',replication resumed in log 'FIRST' at position 28
    020313 9:16:15 Error reading packet from server: bogus data in log event (read_errno 0,server_errno=65535)
    020313 9:17:15 Slave: Failed reading log event, reconnecting to retry, log 'FIRST' position 28
    020313 9:17:15 Slave: reconnected to master 'rep@192.168.20.221:3306',replication resumed in log 'FIRST' at position 28
    020313 9:17:15 Error reading packet from server: bogus data in log event (read_errno 0,server_errno=65535)


    what do you think?did i miss something in the installation?Please help?

  2. #2
    Making a better wheel silver trophy DR_LaRRY_PEpPeR's Avatar
    Join Date
    Jul 2001
    Location
    Missouri
    Posts
    3,428
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    i don't really know anything about replication in MySQL, but in the my.cnf's, `[mysql]' should be `[mysqld]'. maybe that's the problem?
    - Matt ** Ignore old signature for now... **
    Dr.BB - Highly optimized to be 2-3x faster than the "Big 3."
    "Do not enclose numeric values in quotes -- that is very non-standard and will only work on MySQL." - MattR


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •