SitePoint Sponsor

User Tag List

Results 1 to 4 of 4

Hybrid View

  1. #1
    SitePoint Member
    Join Date
    Dec 2007
    Location
    California
    Posts
    18
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Having some trouble getting Ruby on Rails working

    Well i'm an absolute RoR newbie. Lets get that out of the way first. I started learning Rails slowly a few months ago, following the Lynda.com tutorials. Anyhow, when I went through his tutorial on the site I had no problem getting everything ready to code in Rails. I had Leopard already on my Mac and it came with everything i needed. Great. The other day I had to reinstall Leopard on my Mac because of some problems. I Erase and Installed the OS and when i did this i assumed that i was once again going to have no problem getting Ruby on Rails. After the clean install was all done, I installed MySQL and got it working on my Mac, then i go to update Rails just to double check things...and i get this in my Terminal (look to the attached PNG). Trying to run my script/server in the App gets the same message. So thats where I'm stuck.

    ANY insight and help would be very much appreciated.
    Attached Images Attached Images
    ANGRY.illustration San Luis Obispo County Web Design

  2. #2
    SitePoint Member
    Join Date
    Jan 2008
    Posts
    11
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    looks like a permissions error did you try from the console?
    sudo gem install -v=1.2.5 rails

    -=Sam

  3. #3
    l 0 l silver trophybronze trophy lo0ol's Avatar
    Join Date
    Aug 2002
    Location
    Palo Alto
    Posts
    5,329
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Yeah, you just need to sudo it first because it gets installed in some deeper-level files. If you're like me and aren't running as an administrator, you'll first have to switch users: "su administrator-username-here"

  4. #4
    SitePoint Member
    Join Date
    Dec 2007
    Location
    California
    Posts
    18
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Perfect! Completely forgot about using sudo. Thanks a bunch guys.
    ANGRY.illustration San Luis Obispo County Web Design


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •