SitePoint Sponsor

User Tag List

Results 1 to 5 of 5
  1. #1
    SitePoint Enthusiast
    Join Date
    Oct 2002
    Posts
    54
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    IE Transparency: Last PNG on Page Tages Ages to Load?

    Hi there,

    I am using this solution to make PNG's transparent (IMG tags):

    http://homepage.ntlworld.com/bobosola/

    This works fine - however the last PNG on the page in IE6 takes ages to load and appears to slow the page down

    Anyone got any ideas how to fix this? It is always the last one for some reason?

    Thanks!

    Jonno.

  2. #2
    The CSS Clinic is open silver trophybronze trophy
    Paul O'B's Avatar
    Join Date
    Jan 2003
    Location
    Hampshire UK
    Posts
    40,549
    Mentioned
    183 Post(s)
    Tagged
    6 Thread(s)
    Have you uploaded the blank image as mentioned in the instructions? Assuming you are using that version.

    Otherwise we will need to see some code.

  3. #3
    SitePoint Enthusiast
    Join Date
    Oct 2002
    Posts
    54
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    At that very URL (the instructions link) if you ctrl+f5 the page in IE6 it sticks loading car.png. Seems to be a bug with the fix?

    Tried on 2 PCs.

    EDIT: It only appears to happen on the imagemap version it seems.
    EDIT 2: Infact - the problem only occurs only when the code is included in a javascript file? I have tried removing defer="defer" too.
    Last edited by jonno; Jan 2, 2008 at 03:51.

  4. #4
    The CSS Clinic is open silver trophybronze trophy
    Paul O'B's Avatar
    Join Date
    Jan 2003
    Location
    Hampshire UK
    Posts
    40,549
    Mentioned
    183 Post(s)
    Tagged
    6 Thread(s)
    At that very URL (the instructions link) if you ctrl+f5 the page in IE6 it sticks loading car.png.
    I have no problems on that page with IE6 even when refreshing. Are you using an old version of the standalone IE's perhaps ot have you tried clearing your cache.

    I have seem problems with the "defer" method before which Is why I never use the pngfix but apply the filter in the css. IIRC the problem was when the blank image had no been uploaded as I mentioned above.

    Code:
    age in IE6 takes ages to load and appears to slow the page down
    Yes this is a common problem with pngs and the alpha image loader and once you have more than one or two then Ie slows to a crawl. There is nothing you can do about this.

    You could try a different script or perhaps use a method like this that just gives IE index transparency instead.

    Do you have a link to your page and then we can see if we are getting the same results.

  5. #5
    SitePoint Enthusiast
    Join Date
    Oct 2002
    Posts
    54
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    i've sorted the problem out by using an 8bit png with some matte. i have your supersleight link a try but it was taking too long to render the pngs causing the screen to blink.

    thanks anyway!

    Jonno.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •