I have a form that has all the patient fields and it submits back to the appropriate controller action to initialize a new patient object and save the record.

I am getting this exception:

Code:
Mysql::Error: Column 'weight' cannot be null: INSERT INTO patients (`address1`, `city`, `status`, `address2`, `prognosis`, `weight`, `zip_code`, `gender`, `height`, `date_of_birth`, `first_name`, `last_name`, `state`) VALUES(NULL, NULL, NULL, NULL, '', NULL, NULL, '', NULL, NULL, '', '', NULL)
As you can see all values are NULL!

This is the code that is generating the error:

Code:
      
p = Patient.new(params[:patient])
p.save
Before calling the save method, I even tried outputting all of the attributes and they all return the values I entered into the form. Where is it failing? Is it my rails installation?

If I change all the table fields to allow null values, the patient record is saved (obviously completely blank).

Also, to convince myself it is not me... I enabled the patient scaffold and tried to create a new patient through the generated form and it is giving the same exact error!

Any ideas?