SitePoint Sponsor

User Tag List

Results 1 to 3 of 3
  1. #1
    SitePoint Member
    Join Date
    Mar 2002
    Posts
    2
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    CSS & iframe/layer help needed please

    Hi all,

    perhaps someone can help me with a problem I am having. I have a css defined, and I use the following
    code in my main page

    <iframe id="article" class="article" src="article.html"></iframe>
    <layer id="article" class="article" src="article.html"></layer>

    in my .css file I have

    layer.article {list of props/values}
    iframe.article {list of props/values}

    Both IE and Netscape completely ignore the css for this frame. My css is being used for other DIV frame that I have defined.

    Has anyone any ideas how I can get this to work please?
    I need to define background-color, font info, height, width etc...

    As a secondary problem for this, I use the ID tag to move these frames around. This works fine in Netscape 4.75, but in Netscape 6 and IE 5.0 I cannot get the frame positioning to work using these IDs.

    Any help/suggestions very much appreciated.

  2. #2
    Gone!
    Join Date
    Aug 2001
    Location
    Witty Location Parody
    Posts
    3,889
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Try defining your CSS as

    .article {list of props/values}

    ect and dont add the iframe or layer. Also you could try defining the CSS for the iframe in te actual source of the iframes source file.

    Just trial and error although I would use DIV instead of layer for your layers, but thats just me.

    Im not hot on CSS so forgive if I talk rubbish everyone.

  3. #3
    SitePoint Member
    Join Date
    Mar 2002
    Posts
    2
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hi Glen,

    thanks for the reply. I have tried using the .article
    in my css, but that does not work either. I only seem
    to have problems with css and iframe/layer tags, and also with the IDs of these tags.

    I was wondering if this is a known problem, or if I am doing something silly.

    I cannot use div tags here, as I need to reference an outside src file.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •