SitePoint Sponsor

User Tag List

Results 1 to 3 of 3
  1. #1
    SitePoint Evangelist NokX's Avatar
    Join Date
    Feb 2003
    Location
    Knoxville, TN
    Posts
    523
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    "Unknown Method" with xpath and "starts-with"

    what's weird is only two people testing have had this issue, and we're all using the same exact version of IE to attempt to duplicate this issue.

    the problem crops up when this is run...

    Code JavaScript:
    var sourceNodes = docRoot.selectNodes('List/Trans[starts-with(@_Source, "' + oldPath + '")]');

    and the error is something like...

    "Unknown Method" List/Trans[-->starts-with(@<--_Source, "a path")]

    any ideas why this is and why it might just be affecting one or two machines?

  2. #2
    Programming Team silver trophybronze trophy
    Mittineague's Avatar
    Join Date
    Jul 2005
    Location
    West Springfield, Massachusetts
    Posts
    17,036
    Mentioned
    187 Post(s)
    Tagged
    2 Thread(s)

    method

    Other than possible differences in javascript version support, I have never heard of the "_Source" attribute. Is this in a custom DTD?

  3. #3
    SitePoint Evangelist NokX's Avatar
    Join Date
    Feb 2003
    Location
    Knoxville, TN
    Posts
    523
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    it's a custom attribute


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •