SitePoint Sponsor

User Tag List

Results 1 to 6 of 6
  1. #1
    SitePoint Member
    Join Date
    Nov 2007
    Location
    Vancouver BC
    Posts
    3
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Question beginner with ror seeking some tips on getting started

    I have just downloaded the book
    "Build Your Own Ruby On Rails Web Applications
    by Patrick Lenz" and I have installed instant rails and all seems to be ok.

    my question is - why cant I properly execute The rails command wich takes a single parameter:""apparently!"".

    when I try and set up my directory by typing:
    $ rails shovell
    create
    create app/controllers
    create app/helpers
    create app/models
    create app/views/layouts
    create config/environments
    create components
    create db
    create log/server.log
    create log/production.log
    create log/development.log
    create log/test.log

    in the command window it keeps telling me that "create" is not recognized as an internal or external command.

    Im sure I have forgoten to do somthing simple but I cant figure this out!
    im all fired up and very eager to learn ror, just need to get over the first few hurdles to get a grasp on using this development tool and continue learning from this awesome book...

    any tips or info would be much appreciated....

    Thanks in advance
    Matt BW

  2. #2
    SitePoint Member
    Join Date
    Nov 2007
    Location
    Vancouver BC
    Posts
    3
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    ok i figured out my first question but now I am having a problem starting my application using webrick. My directory is set up but I cant start the application...

    Can anyone help with this issue?

    thanks
    Matt

  3. #3
    SitePoint Addict
    Join Date
    Jan 2006
    Posts
    268
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    can you be more specific what happens when you try?
    Are you getting an error message? (if so, paste here)
    If you give someone a program,
    you will frustrate them for a day;
    if you teach them how to program,
    you will frustrate them for a lifetime.

  4. #4
    SitePoint Guru
    Join Date
    Aug 2005
    Posts
    986
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Did you change directory into shovell, by typing this:

    Code:
    cd shovell
    After that you can type this:

    Code:
    ruby script/server
    This ought to start the server

  5. #5
    SitePoint Member
    Join Date
    Nov 2007
    Location
    Vancouver BC
    Posts
    3
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Thumbs up thanks im grinning from ear to ear...!

    thanks for the tips!

    im onto the next step....

  6. #6
    SitePoint Member
    Join Date
    Nov 2007
    Posts
    2
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by Fenrir2 View Post
    Did you change directory into shovell, by typing this:

    Code:
    cd shovell
    After that you can type this:

    Code:
    ruby script/server
    This ought to start the server


    hey all.. i'm also following the pdf download 'RoR - build your own web apps'.
    When i type "ruby script/server" i get the following..

    iMac:~/rubyonrails/shovell mdskinner$ ruby script/server
    ./script/../config/boot.rb:7:in `require': no such file to load -- ./script/../config/../vendor/rails/railties/lib/initializer (LoadError)
    from ./script/../config/boot.rb:7
    from script/server:2:in `require'
    from script/server:2


    anyone know why??..


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •