SitePoint Sponsor

User Tag List

Results 1 to 16 of 16

Hybrid View

  1. #1
    SitePoint Enthusiast
    Join Date
    May 2006
    Posts
    43
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    uploading troubles

    I'm having troubles with my MultiUploader. It works and everything, but it will not let me upload more than 2MB's at a time, and i checked MAX_FILE_SIZE and POST_MAX_SIZE and the values were....

    MAX_FILE_SIZE: 8388608 bytes or 8MB
    POST_MAX_SIZE: 8388608 bytes or 8MB

    I tried changing it with PHP's ini_set, but i can only retrieve the values with ini_get..everytime I tried changing it with ini-set, it would never actually change. I also tried lookg on other websites and through search engines, but I cannot seem to find anything. If anyone has any ideas, please post them.

    Thank you,

    Enjoii

  2. #2
    We're from teh basements.
    Join Date
    Apr 2007
    Posts
    1,205
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Error message?

  3. #3
    SitePoint Enthusiast
    Join Date
    Oct 2007
    Posts
    68
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    The script itself probabally has a max file size,

    Check the PHP settings, in the config/settings file.
    Kieran Allen, 16 years old
    Full time PHP developer,
    With 5 years experience in web development.
    www.kieran.in .. my blog.

  4. #4
    Theoretical Physics Student bronze trophy Jake Arkinstall's Avatar
    Join Date
    May 2006
    Location
    Lancaster University, UK
    Posts
    7,062
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    I think you are looking at the wrong PHP.ini settings.

    Try changing the value of memory_limit, not just post_max_size and upload_max_filesize.
    Jake Arkinstall
    "Sometimes you don't need to reinvent the wheel;
    Sometimes its enough to make that wheel more rounded"-Molona

  5. #5
    SitePoint Enthusiast
    Join Date
    Oct 2007
    Posts
    68
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    To sum this up, check all the following things:

    • memory_limit 32M
    • max_execution_time
    • max_input_time
    • LimitRequestBody (in apache, sometimes it limits bodies to 512kb)
    • MAX_FILE_SIZE
    • POST_MAX_SIZE


    To show php related settings create a file with the following contents

    PHP Code:
    <?php
    phpinfo
    ();
    ?>
    If you aren't dynamically changing the configurations then you should be able to see the static settings.
    Kieran Allen, 16 years old
    Full time PHP developer,
    With 5 years experience in web development.
    www.kieran.in .. my blog.

  6. #6
    SitePoint Evangelist superuser2's Avatar
    Join Date
    Aug 2006
    Posts
    598
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Are you looking at php.ini when you get those? Make sure there's not an htaccess in the way.

    Also, is this dedicated or shared? Because if it's shared even your custom php.ini may have a limit it can't over-ride. Talk to the host.

  7. #7
    SitePoint Enthusiast
    Join Date
    May 2006
    Posts
    43
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I did check :

    POST_MAX_SIZE = 8M
    max_execution_time = 30

    -------------------------

    these are the only settings I found throughout phpinfo(). I did find upload_max_filesize in phpinfo(). And i noticed it was set to 2MB's. I tried also changing this with ini_set, but no luck. I then tried looking on the net , and found someone saying it could only be changed through php.ini or httpd.conf.

  8. #8
    We're from teh basements.
    Join Date
    Apr 2007
    Posts
    1,205
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by Enjoii View Post
    I then tried looking on the net , and found someone saying it could only be changed through php.ini or httpd.conf.
    They were wrong. It's either a PHP_INI_ALL or PHP_INI_PERDIR setting, depending on version. That assumes the necessary overrides are allowed in your virtual host setup though.

  9. #9
    SitePoint Enthusiast
    Join Date
    Oct 2007
    Posts
    68
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Theres also a setting in httpd.conf, with the max body size.
    Kieran Allen, 16 years old
    Full time PHP developer,
    With 5 years experience in web development.
    www.kieran.in .. my blog.

  10. #10
    Theoretical Physics Student bronze trophy Jake Arkinstall's Avatar
    Join Date
    May 2006
    Location
    Lancaster University, UK
    Posts
    7,062
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    And what is it's alias?

    Can't find anything there about it...
    Jake Arkinstall
    "Sometimes you don't need to reinvent the wheel;
    Sometimes its enough to make that wheel more rounded"-Molona

  11. #11
    SitePoint Enthusiast
    Join Date
    Oct 2007
    Posts
    68
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    LimitRequestBody directive

    --- ref: ---

    http://httpd.apache.org/docs/1.3/mod...mitrequestbody
    Kieran Allen, 16 years old
    Full time PHP developer,
    With 5 years experience in web development.
    www.kieran.in .. my blog.

  12. #12
    Theoretical Physics Student bronze trophy Jake Arkinstall's Avatar
    Join Date
    May 2006
    Location
    Lancaster University, UK
    Posts
    7,062
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Yup - good point.

    Are you working on your localhost, dedicated server or shared hosting?
    Jake Arkinstall
    "Sometimes you don't need to reinvent the wheel;
    Sometimes its enough to make that wheel more rounded"-Molona

  13. #13
    SitePoint Enthusiast
    Join Date
    Oct 2007
    Posts
    68
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by arkinstall View Post
    Yup - good point.

    Are you working on your localhost, dedicated server or shared hosting?
    Who you referring to, me or the author?
    Kieran Allen, 16 years old
    Full time PHP developer,
    With 5 years experience in web development.
    www.kieran.in .. my blog.

  14. #14
    Theoretical Physics Student bronze trophy Jake Arkinstall's Avatar
    Join Date
    May 2006
    Location
    Lancaster University, UK
    Posts
    7,062
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    The author.
    Jake Arkinstall
    "Sometimes you don't need to reinvent the wheel;
    Sometimes its enough to make that wheel more rounded"-Molona

  15. #15
    SitePoint Enthusiast
    Join Date
    May 2006
    Posts
    43
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    i'm working off a webhost. I had a dedicated server, but I do not own it anymore.

  16. #16
    SitePoint Enthusiast
    Join Date
    May 2006
    Posts
    43
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thank you guys for all your input, by I have reached a solution. I added a .htaccess file to my public_html, and changed upload_max_filesize to what I needed it to be, and I checked it through ini_get and phpinfo(), and the value was there.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •