SitePoint Sponsor

User Tag List

Results 1 to 7 of 7
  1. #1
    SitePoint Addict Manna's Avatar
    Join Date
    Apr 2006
    Location
    Vancouver, WA
    Posts
    340
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    suckerfish not working

    I have been reading lots of posts on suckerfish menus and cannot get mine to work in any browser. The horizontal menu's 2nd item has a drop down list that does not show. When I remove the position:absolute then it does show but it will not go away (so the hover does not work). I am not sure where I have gone wrong. Could someone point me in the right dirction?

    Thank you

    http://www.premiumwebsites.net/sampl...ne/index.shtml

  2. #2
    padawan silver trophybronze trophy markbrown4's Avatar
    Join Date
    Jul 2006
    Location
    Victoria, Australia
    Posts
    4,117
    Mentioned
    28 Post(s)
    Tagged
    2 Thread(s)
    You've missed the most important part

    Code:
    #nav li:hover ul { left: 0}
    The suckerfish menu hides the nested ul way of left -9999px.
    Then when you hover over a li element it sets the the nested ul back to left: 0; making it re-appear directly below the li element.

    You shouldn't change the positioning or font-size of the menus or you'll make it do a little jig and look unprofessional.

  3. #3
    SitePoint Addict Manna's Avatar
    Join Date
    Apr 2006
    Location
    Vancouver, WA
    Posts
    340
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thank you so much for pointing that out. I have learned so much form this forum.

  4. #4
    SitePoint Addict Manna's Avatar
    Join Date
    Apr 2006
    Location
    Vancouver, WA
    Posts
    340
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I do not see where I have changed the font size, but it does to a little jog upon hover. Also the drop down starts just below the navigation bar image. Is there a way to get it to start just below the words so it covers the bottom part of the image and does not have a gap?

    Thanks

  5. #5
    SitePoint Addict Manna's Avatar
    Join Date
    Apr 2006
    Location
    Vancouver, WA
    Posts
    340
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Solved the positioning problem with a negative top value.

  6. #6
    padawan silver trophybronze trophy markbrown4's Avatar
    Join Date
    Jul 2006
    Location
    Victoria, Australia
    Posts
    4,117
    Mentioned
    28 Post(s)
    Tagged
    2 Thread(s)
    Solved the positioning problem with a negative top value.
    It would be better to correct the initial problem than setting a value and then countering it with a patch ... but whatever works.

  7. #7
    SitePoint Addict Manna's Avatar
    Join Date
    Apr 2006
    Location
    Vancouver, WA
    Posts
    340
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    A little to criptic for me...


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •