SitePoint Sponsor

User Tag List

Results 1 to 1 of 1
  1. #1
    Always learning kigoobe's Avatar
    Join Date
    May 2004
    Location
    Paris
    Posts
    1,565
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    extremely bizzare, browser loosing session data for no reason ...

    Last night there was an auto windows update. I don't know if this event has anything to do with what's happening since this morning, but here's the issue.

    I am doing my pages as

    Code PHP:
    ob_start();
    include 'top.php';
    // bla bla bla ...
    where, top.php handles all session issues, top banner, etc. Problem, since this morning, in one of the pages, session is getting lost. Means, while I surf the site, on coming to that particular page, I don't see any session data. On doing a print_r, I found that there's no session data available in that particular page. Only in IE, I'm still having the sessions, in Opera, FF and Safari, there's no session passing.

    Strange, that this page also handles the session in exactly the same way as the rest (thro' top.php). This is happening whether I go to that page thro' a link, or just enter the url directly on the address bar. And, as I found, this is only for a particular page !!!

    EDIT After some more hit and try, I found that it's the $_COOKIE that's not getting passed in that particular page ...



    Edit:


    Just to give an update. The issue is solved now. After looking around for sometime when I couldn't understood what went wrong, I cleaned all the cookies and session and then went for a log in again ... this, has solved the issue ... bizzare !!!
    Last edited by kigoobe; Oct 11, 2007 at 04:42.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •