SitePoint Sponsor

User Tag List

Results 1 to 2 of 2
  1. #1
    ::==:: Bonzo_CS's Avatar
    Join Date
    Dec 2003
    Location
    (Cardiff Wales)
    Posts
    747
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Problems connecting using ftp_connect

    Hi all,

    I seem to have hit an issue, which I assume to be quite common if using ftp_connect.

    Basically I have a x2 1&1 servers where I have written a script to regularly retrieve files from one server to the other.

    I am basically using the same script as shown on php.net (click here).

    Anyway the problem is I am trying to connect using an IP reference such as:
    $conn_id = ftp_connect('000.000.000.000');
    If I try connecting using my main username and password which I use to FTP from the command line it denies the connection on the authentication of these values. However if I set up a user within a virtual host under a specific domain, but still using the IP in the connect reference, it will connect without problems?

    Why does is not seem to like the username/password of the main server account to which I can SSH or FTP from using the command line, but accept the virtual host values?

    In case your wondering I can't use a vhost account to solve this as it means I cannot go above the root of the vhost which is where the files are?

    Thanks

  2. #2
    ::==:: Bonzo_CS's Avatar
    Join Date
    Dec 2003
    Location
    (Cardiff Wales)
    Posts
    747
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thought I'd work around it by creating a secondary user with the correct access levels and that seemed to have worked!



Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •