SitePoint Sponsor

User Tag List

Results 1 to 4 of 4
  1. #1
    SitePoint Enthusiast
    Join Date
    Apr 2007
    Posts
    54
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    User Authentication only works in LOCAL not on web.

    I have my web app through visual studio and if i run it locally pointing to the production connectionstring, it will authenticate users and allow new users to be inputted. When i go the web server where the site lives, it will allow for users to input but it will not authenticate the user. Could anybody tell me what i'm missing. Do i have to <clear /> out the providers before specifying them. My application name is also the same match on the application table in sql server so i know its not the app. name. I'd appreciate any help. Here is the web.config.

    I've already tried to change my application name and i've seen this link also but still can't seem to resolve this. http://forums.asp.net/p/949781/1154939.aspx

    ---------------------------------------------------------------

    <configuration>

    <connectionStrings>−
    <add name="SouthCoastProd" connectionString="Data Source=sql2k510.discountasp.net;Initial Catalog=SQL2005_410515_southcoast;User ID=SQL2005_***;Password=******;" providerName="System.Data.SqlClient"/>−
    </connectionStrings>

    <system.web>

    <!--

    Set compilation debug="true" to insert debugging
    symbols into the compiled page. Because this
    affects performance, set this value to true only
    during development.

    Visual Basic options:
    Set strict="true" to disallow all data type conversions
    where data loss can occur.
    Set explicit="true" to force declaration of all variables.

    -->
    <compilation debug="true" strict="true" explicit="true">
    </compilation>

    <pages>

    <namespaces>
    <clear/>
    <add namespace="System"/>
    <add namespace="System.Collections"/>
    <add namespace="System.Collections.Specialized"/>
    <add namespace="System.Configuration"/>
    <add namespace="System.Text"/>
    <add namespace="System.Text.RegularExpressions"/>
    <add namespace="System.Web"/>
    <add namespace="System.Web.Caching"/>
    <add namespace="System.Web.SessionState"/>
    <add namespace="System.Web.Security"/>
    <add namespace="System.Web.Profile"/>
    <add namespace="System.Web.UI"/>
    <add namespace="System.Web.UI.WebControls"/>
    <add namespace="System.Web.UI.WebControls.WebParts"/>
    <add namespace="System.Web.UI.HtmlControls"/>
    </namespaces>
    </pages>

    <!--

    The <authentication> section enables configuration
    of the security authentication mode used by
    ASP.NET to identify an incoming user.

    -->

    <authentication mode="Forms">
    <forms loginUrl="login.aspx"/>
    </authentication>

    <roleManager defaultProvider="SqlRoleProvider" enabled="true">

    <providers>
    <add name="SqlRoleProvider" type="System.Web.Security.SqlRoleProvider" connectionStringName="SouthCoastProd" applicationName="southcoastt"/>
    </providers>
    </roleManager>

    <membership defaultProvider="SqlMembershipProvider">

    <providers>
    <add name="SqlMembershipProvider" type="System.Web.Security.SqlMembershipProvider" connectionStringName="SouthCoastProd" applicationName="southcoastt" enablePasswordRetrieval="true" enablePasswordReset="true" minRequiredNonalphanumericCharacters="0" minRequiredPasswordLength="5" requiresQuestionAndAnswer="false" requiresUniqueEmail="true" passwordFormat="Encrypted"/>
    </providers>
    </membership>

    <profile defaultProvider="SqlProfileProvider">

    <providers>
    <add name="SqlProfileProvider" type="System.Web.Profile.SqlProfileProvider" connectionStringName="SouthCoastProd" applicationName="southcoastt"/>
    </providers>

    <properties>
    <add name="Title" type="System.String"/>
    <add name="FirstName" type="System.String"/>
    <add name="LastName" type="System.String"/>
    <add name="Address" type="System.String"/>
    <add name="City" type="System.String"/>
    <add name="State" type="System.String"/>
    <add name="ZipCode" type="System.String"/>
    <add name="Country" type="System.String"/>
    <add name="Phone" type="System.String"/>
    </properties>
    </profile>
    [redacted]

    <!--

    The <customErrors> section enables configuration
    of what to do if/when an unhandled error occurs
    during the execution of a request. Specifically,
    it enables developers to configure html error pages
    to be displayed in place of a error stack trace.
    -->
    <!--<customErrors mode="Off">
    -->

    <!--
    <error statusCode="403" redirect="NoAccess.htm" />
    <error statusCode="404" redirect="FileNotFound.htm" />
    -->
    <!--
    </customErrors>-->
    </system.web>
    Last edited by wwb_99; Sep 21, 2007 at 10:43. Reason: security

  2. #2
    SitePoint Wizard
    Join Date
    Feb 2007
    Posts
    1,274
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Strange.

    You are sure that the directory with your web.config is a directory defined as an application? And that the application is ASP.NET 2.0?

  3. #3
    SitePoint Enthusiast
    Join Date
    Apr 2007
    Posts
    54
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I figured it out. Thanks anyways.

  4. #4
    SitePoint Guru Wullie's Avatar
    Join Date
    Oct 2002
    Location
    Greenock, Scotland
    Posts
    701
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    What was the problem Developer1983, I think I've ran into the same problem and am curious what you done to resolve it.
    ASP.NET Freelance Web Developer
    Bored? Check out my photography folio at Flickr


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •