SitePoint Sponsor

User Tag List

Results 1 to 6 of 6
  1. #1
    SitePoint Addict
    Join Date
    Mar 2004
    Posts
    260
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Column width doesn't work for me :(

    Please have a look at http://www.truedesign.co.uk/nipperbout/email.html
    (it's for an email newsletter, hence the slightly strange style specs)

    What I don't get is why are the 3 columns with the content not the same width. (viewing with FF and Safari)

    They are supposed to be 200px each, but the left hand column is wider.WHY?

    Thanks for any help!

  2. #2
    SitePoint Wizard
    Join Date
    Jul 2003
    Location
    Kent
    Posts
    1,921
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Not sure.

    However, you have three nested tables inside one table, and you only need the first table to produce this layout (assuming you wish to stay with tables that is...)

    You need four rows by three coulmns, then you use colspan to merge the columns you wish to be one wider column, not three little ones.

    Not that many peopel recommend using tables of course.

  3. #3
    SitePoint Addict
    Join Date
    Mar 2004
    Posts
    260
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks for the reply, tables are used because it's an email newsletter.
    http://www.sitepoint.com/article/cod...il-newsletters
    That's that. (You're propably right about the number of tables.)

    So, the question remains:
    Why are there not three equal columns at 200px each???

  4. #4
    SitePoint Addict
    Join Date
    Mar 2004
    Posts
    260
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    No idea why 200px each does not work. I've now used 33%, 33%, and 34% and that just works ok.

  5. #5
    SitePoint Addict
    Join Date
    Mar 2004
    Posts
    260
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Oh, no it doesn't in Safari!
    What's going on!?!?!?

  6. #6
    SitePoint Addict
    Join Date
    Mar 2004
    Posts
    260
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    It now work if I split up the tables again....
    Mystery.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •