SitePoint Sponsor

User Tag List

Results 1 to 5 of 5
  1. #1
    SitePoint Member
    Join Date
    Sep 2007
    Location
    Red Oak, IA
    Posts
    6
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Simple style sheet problem

    I'm using Wordpress to manage my site. I just redesigned the layout, and I am still having one problem. My links seems to be inheriting one of my <h3> behaviors, and I cannot figure out why.

    <h3> are white on a green field, white with underline on hover, and white after visit.

    My links in articles are green on a white background, black with underline on hover, and are supposed to return to green after visit. The darn things are going white after visit, so they completely disappear into the background after visit.

    I've played with my style.css all morning, and I am just not getting where my problem is. I'm sure this is something really simple, so I'm hoping someone can take the time to go take a look at the site and tell me what's screwed up.

    Thanks in advance.

  2. #2
    masquerading Nick's Avatar
    Join Date
    Jun 2003
    Location
    East Coast
    Posts
    2,215
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Remember that if you have two declarations in your stylesheet that are in conflict of each other, the last declaration (i.e the most recently read by the browser) will be the one used.
    Nick . all that we see or seem, is but a dream within a dream
    Show someone you care, send them a virtual flower.
    Good deals on men's watches

  3. #3
    SitePoint Member
    Join Date
    Sep 2007
    Location
    Red Oak, IA
    Posts
    6
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    So if my <h3> declaration and link declaration in style.css are in conflict, which they obviously are, outside of changing my color scheme, how can I fix it so that they both work as expected? Thanks for taking the time to answer

  4. #4
    SitePoint Member
    Join Date
    Sep 2007
    Location
    Red Oak, IA
    Posts
    6
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    problem solved, my h3 declaration was missing two characters

  5. #5
    masquerading Nick's Avatar
    Join Date
    Jun 2003
    Location
    East Coast
    Posts
    2,215
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by mlankton View Post
    problem solved, my h3 declaration was missing two characters
    The simple things that we miss for hours trying to solve :-p
    Nick . all that we see or seem, is but a dream within a dream
    Show someone you care, send them a virtual flower.
    Good deals on men's watches


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •