After upgrading to PHP 5.2.4 on Windows XP I was unable to start Apache (1.3)

My investigations determined that something about the extensions (/ext) bundled with the new version were at fault.
If I dumped in all extensions from PHP 5.2.3 I was able to start Apache and run fine.

Reverting to the new 5.2.4 dlls caused the problems to resume.

The only extension dll with a different file size between the PHP versions is php_tidy.dll, but swapping this dll alone with the 5.2.3 variant did not solve the problem.

I thought I'd post in case anyone else has issues. I haven't solved the problem, I'm just running 5.2.4 with the older 5.2.3 dlls.