SitePoint Sponsor

User Tag List

Results 1 to 7 of 7
  1. #1
    SitePoint Zealot
    Join Date
    Sep 2007
    Posts
    128
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Background Image not showing up.

    I have run into a bit of a problem.I am trying to put a tagline background in as well. Please take a look, and see what you can find:

    Code:
    /*
    
    CSS For Ipodtouchcentral.org
    
    */
    
    body {
      font-family: Veranda, Hevletica;
      line-height: 125%;
      padding: 15px;
      background-color: #000000
    }
    
    ul {
      margin-top: 15px;
    }
    
    li {
      font-size: normal;
      list-style-type: none;
    }
    
    p { 
      font-size: "small"
      color: white ;
    }
    
    #tagline p {
      font-style: italic;
      font-family: Georgia, Times, serif;
      border-top: 3px solid;
      border-bottom: 3px solid;
      padding-top: .2em;
      padding-left: .8em;
      margin: 0;
      background: #CDCDCD url(backgrounds/tageline-fade.jpg) repeat-y right bottom;
    }
    
    h1,h2,h3 {
      font-family: "Trebuchet MS", Hevletica, Arial;
      color: white;
    }
    
    
    h1 {
      font-family: "Trebuchet MS", Hevletica;
      font-size: x-large;
      color: white;
      padding-top: 2em;
      padding-bottom: .2em;
      padding-left: .4em;
      margin: 0;
      background: #000000 url(backgrounds/ipodtouch-horizontal.jpg) repeat y right;
    }
    
    
    a {
      font-weight: bold;
      color: #000000;
    }
    
    
    a:link {
      color: #000000;
    }
    
    a:visited {
      color: #003F87;
    }
    
    a:hover {
      text-decoration: none;
      color: white;
      background-color: #82CFFD;
    }
    
    #navigation {
      width: 180px;
      height: 484px;
    }
    
    
    /*
    This stuff has to do with absolute positioning! Oh joy!
    */
    
    
    #navigation, #bodycontent, #header, #tagline {
      position: absolute;
    }
    
    #navigation, #bodycontent {
      top: 7.84em;
    }
    
    #bodycontent {
      left: 13.44em;
      top: 8.13em;
    }
    
    #header, #tagline, #sitebranding {
     width: 100%;
    }

  2. #2
    padawan silver trophybronze trophy markbrown4's Avatar
    Join Date
    Jul 2006
    Location
    Victoria, Australia
    Posts
    4,108
    Mentioned
    28 Post(s)
    Tagged
    2 Thread(s)
    Sorry, your going to need to try harder than "Please take a look and see what you can find".
    If the site is on the net somewhere please post a link, otherwise post the HTML as well - and explain what you are wanting.

  3. #3
    SitePoint Zealot
    Join Date
    Sep 2007
    Posts
    128
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    There is a reason that the tagline p text is bold. Sorry about that.

  4. #4
    SitePoint Wizard bronze trophy Tyssen's Avatar
    Join Date
    Oct 2005
    Location
    Brisbane, QLD
    Posts
    4,067
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    That still doesn't help. Like Mark says, you need to explain in more detail what you want and post all of your code - HTML and CSS.

  5. #5
    padawan silver trophybronze trophy markbrown4's Avatar
    Join Date
    Jul 2006
    Location
    Victoria, Australia
    Posts
    4,108
    Mentioned
    28 Post(s)
    Tagged
    2 Thread(s)
    You're not even trying so neither will I.

    If the site is on the net somewhere please post a link, otherwise post the HTML as well - and explain what you are wanting.

  6. #6
    In memoriam gold trophysilver trophybronze trophy Dan Schulz's Avatar
    Join Date
    May 2006
    Location
    Aurora, Illinois
    Posts
    15,476
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    For starters, change repeat y to repeat-y in your stylesheet. Then check to make sure that the link paths are correct.

  7. #7
    SitePoint Zealot
    Join Date
    Sep 2007
    Posts
    128
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    ok, ok.

    Here is the xhtml page. As you can see, I have not really started working on content yet, just building the frame.

    Code:
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml-1.dtd">
    
    <html xmlns="http://www.w3.org/1999/xhtml">
    
    <head>
    
    <title>Index - Ipodtouchcentral.org</title>
    
    <meta http-equiv="Content-Type" content="text/html; charset= utf-8" />
    
    <link href="style1.css" rel="stylesheet" type="text/css" />
    
    </head>
    
    <body>
    <div id="header>
    
    <div id="sitebranding">
    
    <h1>Ipodtouchcentral.org</h1>
    
    </div>
    
    <div id="tagline">
    
    <p>A community based around the iPods, and other tech.</p>
    
    </div>
    
    </div> <!--end of header div-->
    
    <div id="navigation">
    
    <ul>
    	<li><a href="index.html">Home</a></li>
    	<li><a href="about.html">About Us</a></li>
    	<li><a href="blog.html">Blog</a></li>
    	<li><a href="contact.html">Contact</a></li>
    </ul>
    
    </div> <!--end of navigation div-->
    
    <div id="bodycontent">
    
    <p>Welcome.</p>
    
    </div>
    
    </body>
    
    </html>


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •