SitePoint Sponsor

User Tag List

Results 1 to 4 of 4

Hybrid View

  1. #1
    SitePoint Addict webmistress's Avatar
    Join Date
    Aug 2002
    Location
    Derbyshire, UK
    Posts
    295
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    table data widths. IE not playing...

    I am laying out some data in a table and it should look like this:




    And it does in Firefox and Safari... but IE 6 or 7 is not playing! Here is a preview page. I have set a width on the photo <td> cell and thought that would be ok. It's been a while since I had to use tables in this way, so I am a bit stuck!

    Any help would be very much appreciated.

    Cheers.
    ****************
    The Webmistress

  2. #2
    SitePoint Enthusiast
    Join Date
    Oct 2004
    Location
    Ballymena
    Posts
    69
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    IE is a bit more random than other browsers when it comes to allowing it to decide on table column widths.

    If you ensure you apply an explicit width (using CSS syntax, of course!) to the three cells of your first row, you should be able to achieve the layout you're after in all browsers.

  3. #3
    SitePoint Addict webmistress's Avatar
    Join Date
    Aug 2002
    Location
    Derbyshire, UK
    Posts
    295
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Let me give that a go... I'll be back Thanks.
    ****************
    The Webmistress

  4. #4
    SitePoint Addict webmistress's Avatar
    Join Date
    Aug 2002
    Location
    Derbyshire, UK
    Posts
    295
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    hmm odd... even setting the widths on the first 3 cols (<th> <td> <td>), it doesn't set the width properly. I have checked in IE 7 so far.
    ****************
    The Webmistress


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •