SitePoint Sponsor

User Tag List

Results 1 to 2 of 2
  1. #1
    SitePoint Enthusiast
    Join Date
    Nov 2006
    Posts
    61
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Question Javascript error in IE6/7 on our forums

    We have some forums located here:
    http://tmcyouth.com/forums

    In IE6/IE7 it pops up the following message while I browse the forums or upload attachments:

    A Runtime Error has occurred.
    Do you wish to Debug?
    Line: 27
    Error: 'document.getElementById(...)' is null or not an object

    Unfortunately there isn't an error in firefox or safari so I can't just use Firebug to figure out where the problem is, or in what file. Does anyone know a javascript debug program for IE? Anybody with any guesses as to what it might be?

  2. #2
    SitePoint Guru
    Join Date
    Sep 2006
    Posts
    731
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by obelix View Post
    Unfortunately there isn't an error in firefox or safari so I can't just use Firebug to figure out where the problem is
    From the Opera console:

    TMC Youth Forums - Powered by vBulletin
    http://www.tmcyouth.com/forums/
    Event thread: load
    Error:
    name: TypeError
    message: Statement on line 3: Could not convert undefined or null to object
    Backtrace:
    Line 3 of inline#2 script in http://www.tmcyouth.com/forums/
    var sfEls = document.getElementById("nav").getElementsByTagName("LI");

    I've seen this code/error on another site recently. I don't know its origin, but it's referring to a non-existent element with the id 'nav'.
    It looks like the crutchware needed to simulate a CSS hover effect in I.E.
    Tab-indentation is a crime against humanity.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •