SitePoint Sponsor

User Tag List

Results 1 to 6 of 6
  1. #1
    SitePoint Wizard simplecode's Avatar
    Join Date
    Jun 2006
    Posts
    1,129
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    <br> Problem with Mozilla

    PHP Code:
    I've got a WYSIWYG editor inside an <iframe>... 
     
    I'
    m having trouble accessing this in Watir.  Whilst I can access the <iframe>, 
    I can't find anything else inside the frame that resembles a field to 'use'.
     
    Here'
    s the HTML:
     
    <
    HTML xmlns=\"http://www.w3.org/1999/xhtml\";>
    <HEAD>
    <TITLE>blank_page
    </TITLE>\r\n
    <META http-equiv=Content-Type content="
    text/htmlcharset=UTF-8\">\r\n
    <META content=\"MSHTML 6.00.2900.3086\" name=GENERATOR>
    <LINK href="
    {blah blah}.css\" rel=stylesheet>
    </HEAD>\r\n
    <BODY class=mceContentBody dir=ltr editorId=\"mce_editor_0\">&nbsp;
    </BODY>
    </HTML>"
     
     
     
    When I view the item in FirebugI'm presented with something slightly different, but ultimately I think it's the same.  Still can't see anything useful in here:
     
     
    <iframe width="872" height="239" frameborder="0" id="mce_editor_0" 
    name="mce_editor_0" class="mceEditorIframe" border="0" marginwidth="0" 
    marginheight="0" leftmargin="0" topmargin="0" allowtransparency="true" 
    style="width: 872px; height: 239px;">
     
    <html>
    <head xmlns="http://www.w3.org/1999/xhtml";>
    <base href="{blah blah}"/>
    <title>blank_page
    </title>
    <meta content="text/html; charset=UTF-8" http-equiv="Content-Type"/>
    <link rel="stylesheet" href="{blah blah}.css"/>
    <link rel="stylesheet" href="/javascript/tiny_mce/editor.css"/>
    <link rel="stylesheet" href="{blah blah}.css"/>
    </head>
    <body class="mceContentBody" dir="ltr" spellcheck="false">
    <br _moz_editor_bogus_node="TRUE" _moz_dirty=""/>
    </body>
    </html>
     
    </iframe>
     

     

    I want to remove the line <br _moz_editor_bogus_node="TRUE" _moz_dirty=""/> from the code found in firebug.


    Please help me ....
    thanks 

  2. #2
    padawan silver trophybronze trophy markbrown4's Avatar
    Join Date
    Jul 2006
    Location
    Victoria, Australia
    Posts
    4,122
    Mentioned
    29 Post(s)
    Tagged
    2 Thread(s)
    Hi,

    That's not your complete code, and's it not easy to know what you are really asking..
    Where about's are you linking the tinymce script?

    You would probably get a better answer from the makers themselves in the support forum.
    http://tinymce.moxiecode.com/punbb/index.php

  3. #3
    SitePoint Wizard simplecode's Avatar
    Join Date
    Jun 2006
    Posts
    1,129
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    ok i am looking into it....
    but the following line is not added in code anywhere but still it is coming in Mozilla but not in IE.....
    any Clue...

    <br _moz_editor_bogus_node="TRUE" _moz_dirty=""/>

  4. #4
    SitePoint Wizard simplecode's Avatar
    Join Date
    Jun 2006
    Posts
    1,129
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    can any one wants to add some more help.

    Thanks

  5. #5
    SitePoint Wizard bronze trophy Immerse's Avatar
    Join Date
    Mar 2006
    Location
    Netherlands
    Posts
    1,661
    Mentioned
    7 Post(s)
    Tagged
    1 Thread(s)
    Code:
    <br _moz_editor_bogus_node="TRUE" _moz_dirty=""/>
    I think that's the Mozilla internal representation of a BR tag. I wouldn't worry about it, it's only displayed in FireBug and it's not actually how it's stored in your data.

  6. #6
    SitePoint Wizard simplecode's Avatar
    Join Date
    Jun 2006
    Posts
    1,129
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Okay thanks for help.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •