SitePoint Sponsor

User Tag List

Results 1 to 7 of 7
  1. #1
    SitePoint Zealot lord's Avatar
    Join Date
    Nov 2003
    Location
    sLOVEnia
    Posts
    117
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    require_gem is obsolete

    Hello folks

    I installed latest ruby and gems version for WINXP and now I get error when I want to run Webrick.

    I get "Warning: require_gem is obsolete. Use gem instead"

    Can please somebody help me how to solve this problem.
    I also try to reinstal everything ... but this didn't help me ...

    thanx in advance
    Marko

  2. #2
    SitePoint Enthusiast
    Join Date
    Jun 2007
    Location
    Miami, FL
    Posts
    92
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

  3. #3
    SitePoint Zealot lord's Avatar
    Join Date
    Nov 2003
    Location
    sLOVEnia
    Posts
    117
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    thanx for reply, so this mean that I should make changes "by hand" in these files?
    Code:
    actionmailer/lib/action_mailer.rb
    actionpack/lib/action_controller.rb
    actionpack/test/controller/assert_select_test.rb
    actionwebservice/lib/action_web_service.rb
    activerecord/benchmarks/benchmark.rb
    activerecord/lib/active_record.rb
    activeresource/lib/active_resource.rb
    railties/environments/boot.rb
    railties/lib/rails_generator.rb
    There isn't any patch or some user-friendly solution?

  4. #4
    SitePoint Enthusiast
    Join Date
    Jun 2007
    Location
    Miami, FL
    Posts
    92
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

  5. #5
    SitePoint Zealot lord's Avatar
    Join Date
    Nov 2003
    Location
    sLOVEnia
    Posts
    117
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    OK, I will update these files later, when I will be at home.

    Thanx again, and have a nice day

  6. #6
    SitePoint Zealot lord's Avatar
    Join Date
    Nov 2003
    Location
    sLOVEnia
    Posts
    117
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I didn't manage to solve this problem, I belive that this changes are for linux version of Ruby.

    Some files I didn't find in my Ruby directory ... in files that I found I made changes but I get the same error.

    Does anybody have working new WIN version of Ruby and with gems 0.9.4?

    There is always an option to install rubygems-0.9.0.zip version ... but this is not what I want.

  7. #7
    SitePoint Evangelist
    Join Date
    Feb 2006
    Location
    Worcs. UK
    Posts
    404
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Just a quick note - I think it is worth pointing out that the issue being raised does not actually cause an error nor prevent you application from working correctly. It is advice that in future you will probably have to update your code. At the moment your code will work fine.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •