this is upsetting dearly, for whatever reason php5 keeps thinking my apache version is the 1.0 series of the 2.0 series. what's the problem GRRR!!! apache 2.0.59 is built from the source, and so is php, but why can't i get past this error.

Configuring SAPI modules
checking for AOLserver support... no
checking for Apache 1.x module support via DSO through APXS... no
checking for Apache 1.x module support... no
checking for mod_charset compatibility option... yes
checking for Apache 2.0 filter-module support via DSO through APXS... no
checking for Apache 2.0 handler-module support via DSO through APXS... expr: non-numeric argument
configure: error: You have enabled Apache 2 support while your server is Apache 1.3. Please use the appropiate switch --with-apxs (without the 2)


here's the code in question used for php5

./configure --prefix=/php5 --libexecdir=/usr/lib/apache2/modules --with-apxs2=/usr/lib/apache2/bin/apxs

it doesn't matter if i use the apxs2filter or the apxs2 NONE of the following will allow the script to go any further. However, but if i use the --with-apxs feature it's continues on, and fails during the middle of the make process. please i know someone else has went through this, so how did you get past this?

I've googled this topic, but it's not really saying anything useful

HELP!!!!

using Ubuntu 7.04 Feisty,Apache 2.0.59, and php 5.2.3