SitePoint Sponsor

User Tag List

Results 1 to 3 of 3
  1. #1
    SitePoint Zealot bazzablue's Avatar
    Join Date
    Mar 2005
    Posts
    113
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    My nav bar has dissappeared in IE7

    I have recently designed and launched a site for a client who informed me this morning that the menu bar is not displaying properly in IE7.

    The site in question is: http://www.edheconference.org

    Anyone able to help me fix this please?

    Thanks in advance.
    Barry

    Snap Designs
    Creating good impressions online and in print

  2. #2
    CSS & JS/DOM Adept bronze trophy
    Join Date
    Mar 2005
    Location
    USA
    Posts
    5,482
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    The problem seems to be the stray double-quote in the rule for ".pic-bio", which is right before the one for ul#nav.

    Please fix your XHTML and (non-pseudo-class related) CSS errors.

    By the way, if you had validated your code, you wouldn't have had to ask us for help this time.
    We miss you, Dan Schulz.
    Learn CSS. | X/HTML Validator | CSS validator
    Dynamic Site Solutions
    Code for Firefox, Chrome, Safari, & Opera, then add fixes for IE, not vice versa.

  3. #3
    SitePoint Zealot bazzablue's Avatar
    Join Date
    Mar 2005
    Posts
    113
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    After posting I went back and looked at the CSS and spotted the quote mark. Haven't got a clue how they got there.

    I did validate the CSS and XHTML but the quote mark most have been inserted accidentally when I updated a margin figure yesterday.

    Thanks for the replies.
    Barry

    Snap Designs
    Creating good impressions online and in print


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •